New error: "Unable to find you tablo"

Had the two tuner model for the last 3 or so months. It’s been working well until last night/this morning. Roku 3 updated to version 6.1 last night, and not sure if that’s the issue, but since then, the Roku app displays "Unable to find your tablo. Please make sure your Tablo is on the same LAN as your roku."

The iPad app connects just fine to the Tablo, all recordings show up, etc. I’ve tried resetting everything multiple times: Roku, router, Tablo. No luck. 

Tablo mac address is: 5087B8002AC7


Delete the Tablo channel on the Roku, then power cycle the Roku and reinstall the Tablo channel.

Yep, did that. A couple times. Still no luck.

@Chrisd Hm. Is the Tablo (or Roku) using an Ethernet? Any chance you can switch to Ethernet from Wi-Fi (or vice versa) to see if this helps?

@TabloSupport No, everything is wi-fi. Strangely, our other Roku 3 in our bedroom works fine, which makes me think it’s on the Roku end. Any reports from other Roku 3 users after the most recent Roku update?


I was in the middle of watching a recording and I got the same error. Nothing seems to be working. Also using a roku 3, however my version is still 5.6.

My only other recommendation which has fixed other Roku problems for me is to factory reset the Roku and re-set it up.

I know you can access from your iPad but can you actually stream to it?

Yes, I can stream from Tablo to the iPad via the Tablo app. And we have an old AppleTV that we use solely for Airplay time to time.

I was able to get ours working again this morning. Reset both the roku and the tablo and after a few hours it just came back. 

@chrisd We haven’t heard of any issues with the new Roku firmware - but that doesn’t mean there aren’t any.

@Becky let us know if you decide to update - and if you have any similar issues.

@Becky Roku will force update your Roku so please report back when running the new firmware. You have no choice in whether you want to upgrade the box.

Double posting just because this is more relative than my first post.

This started happening to me tonight on my downstairs Roku. I was able to connect from my Nexus 10 but it was buffering every 30 seconds so I power-cycled my Tablo. Did not resolve either the buffering or the “tablo not found” issue.

Power-cycled my downstairs Roku but that didn’t fix the problem. Removed the channel from my downstairs Roku and re-added it but still not able to find my tablo.

Went into the Plex channel on my downstairs Roku and was able to connect to my tablo via the Plex-Tablo channel and view recorded shows.

Went upstairs to test the Tablo channel on my upstairs Roku and was able to connect and view recorded shows. Did a system update and verified that I was still able to connect afterwards.

Came back downstairs and again verified that the downstairs Roku couldn’t connect but noticed that it was running a different software version.

Power-cycled my Engenius EAP350 wireless access point and still unable to connect.

Power-cycled my HP 1810-24G managed switch and still unable to connect.

Power-cycled my Supermicro Atom based pfSense firewall and still unable to connect.

My pfSense firewall is my DHCP server and every device on my subnet is issued a static DHCP lease so I know that it is not an issue of my tablo’s or Roku’s IP address changing. I am able to ping the IPs of my tablo and both Rokus no problem, 0 packet loss and <5ms reply over wifi.

At this point I don’t see how it can be a network issue and the only difference I can see between the upstairs Roku and the downstairs Roku is the software version.

Tablo: 4-Tuner, Firmware 2.1.20
Network Switch: HP 1810-24G, Firmware PL.1.9, eCos-3.0, 1_12_8-customized-h
Wireless Access Point: Engenius EAP350, Firmware 1.5.2
Firwall: pfSense 2.1.5-RELEASE
Upstairs Roku: 4200X Roku 3, Version 5.6 build 60
Downstairs Roku: 4200X Roku3, Version 6.1 build 5517

It’s the 6.1 roku software. There are a couple of other threads on this same subject. Check the thread about ver 6.1 FUBAR

I’m having the same issue as claflico.  Same versions as well.  My emails to and from support indicate they are aware of the issue with v. 6.1 Build 5517.  Staying tuned for an update.

I too spent many hours yesterday evening trying to figure out where the issue could be in my LAN.  At least now I know the issue is with the Tablo app and Roku not seeing eye to eye on v. 6.1.

Other than this pesky issue, I’m enjoying the heck out of my Tablo on my other Rokus and other devices.

@chrisd @kcwazzu Just circling back on this: we pushed out a fix last night. You can get the update to the Tablo Roku channel by tapping the ‘check for updates’ button from the Settings menu.

Otherwise, it should update within 24 hours or so.

I am double posting this one as well since I just came upon this thread.  Here is my situation and I’ve also email Tablo support.

As of yesterday evening (sometime) all 3 of my Roku’s are now unable to find my Tablo.  I can access Tablo from the web app and from my IOS devices.  I can also stream Netflix and Hulu on the Roku’s so it isn’t a connection to my wireless issue.

I’ve done the following:
  • Unplugged the Tablo, waited 10 minutes and then plugged it back in.  3X
  • Pushed the ‘blue’ button on the back of the Tablo a couple of times.
  • Unplugged each Roku, waited 10 minutes and then plugged it back in.  3X
  • Reset the router a couple of times.
  • Disconnected from the Tablo via web and reconnected.
  • I’ve pinged the Tablo on the network.
I have a Tablo 2 Channel
  • Tablo Software: 2.1.20
  • App: 1.2.1(77)

I know 2 of my 3 Roku’s are old(er) but they were working fine yesterday.

1) Model: 2720X - Roku 2
    Software Version: 6.1  build 5521
I’ve done a complete back to factory setting on this one.  Tells me software is up to date.  Last updated January 14th.

2) Model: 3050X - Roku 2 XD
    Software Version: 6.1  build 5518
I’ve done a complete back to factory setting on this one.  Tells me software is up to date.  Last updated January 14th.

3) Model: 2700X - Roku 2 LT
    Software Version: 6.1  build 5521
I’ve done a complete back to factory setting on this one.  Tells me software is up to date.  Last updated January 14th.

Anyone have any suggestions?    HELP !!!


See your own thread for my response.


This happened to me because I was using version 1.0 build 9. On my Roku account page, the channel was called “Tablo”. The new channel is called “Tablo TV”. So I deleted the channel and re-added it using the link from the Tablo website.

That resolved it.  Apparently I had the old “Roku” app…  The new one has a RESUME function.  This rocks!

Thank You so Much !!!