Netgear Nighthawk MR80 wifi mesh router and MS80 satellites

Netgear Nighthawk MR80 wifi mesh router with 2 MS80 satellites. 63 devices on the network.

Got it to work, wasted many hours trying over and over between wifi and ethernet. It would appear on the router but the app would always get to the point of “Wifi setup completed. Tablo will go to the next screen when it’s ready.” and it would never move beyond. Calling support they would advise the device wasn’t registered to my account yet but unfortunately gave me no assistance other than asking for screenshots of errors and the mystatus page.

I went to try again and here are the things I did - it then worked:

  1. I had tried to automatically update the router but it never appeared to have an update. I logged into a satellite to check its setup and found it HAS to be done manually, so I googled for the update. There was a file for both the router and satellite so I got both ( and was able to also update the router manually. It’s likely this alone fixed the issue but I had changed the things below before I discovered this.
  2. Changed the 2.4 wifi from “auto” channel to “11”.
  3. Unchecked “Enable Metering” for the internet (didn’t realize this was even on for my router).
  4. I had previously set a static IP for the router. Went ahead and set TV IP to be static as well.

If you are having issues and figure them out for your router, please come back here and post your router model and the steps you took to resolve it to help other people. :slight_smile: