cannot find Tablo

I’ll preface that I’m a systems engineer by profession, so feel free to fire off anything you think may be complex…

So I just purchased my Tablo and activated last week. My main problem is that I cannot use any of the full functionality that comes with the 30 day trial. I can currently connect to the Tablo via my Android app. I can only view live TV. Options to view the Prime Time, TV Shows, Movies, Sports sections are greyed out. My guide only goes for 24 hours. My firmware is out of date and has not updated (I believe the device will do so automatically upon booting, maybe I’m wrong).

I inquired with support to confirm that this was not a previously used device and it was not. They could also see the 30 day free trial was activated. The support tech indicated that it would be a good idea to update my firmware by going to So this tells me they’re able to see the device status, which tells me this thing is able to communicate to the outside world. When I go to, it says ‘No Tablo was found on your network’. The Tablo is hard wired to my router. What am I missing? Are there any special ports that I should check to make sure are opened? I know the Tablo needs to communicate with an outside server for this to work. Does anyone know what IP (or hostname) and ports the Tablo must communicate with on the Tablo side for this to work? The technical support over email is slow and I’m not able to call in during support hours while being in front of this thing because their support only runs during normal working hours, which sucks… because I’m at work. I mean really, no weekend call support?

At any rate, just wondering if anyone has any advice or experience with this issue. I really want to like this product but I can’t get off the ground.

Thanks for your help!

If we assume that all devices you are trying to connect are inside house, then those devices need to be using the same subnet. As an example something like 192.168.1.xx. Most routers have tools that can indicate what the addresses the devices have assigned to them. Some WIFI extenders it also have dhcp enabled.

For the initial setup I used chrome on windows with

Any devices that would connect directly to the Tablo on my private network (android app on phone) can connect to the Tablo fine. The internal addressing is fine. Everything is on

For me, resolves to, which is public IP space, so my assumption is that the Tablo must be communicating outside of my internal network to be seen via, correct me if I’m wrong though. Which is why I’m wondering if something on my end is blocking traffic either to/from the Tablo servers. I also suspect if I fix this connection, then maybe the unusable features will be usable.

I have a dhcp reservation for the Tablo.

I tried with chrome, firefox, and IE. In neither case is it able to find the Tablo. Though, I’m not sure browser would matter in finding the device. But for good measure, I’ve stuck with chrome since that is preferred.

Well it use to be that only worked in Chrome. All other browsers were functionally unstable. And it’s not the address of It’s the LAN address of the device accessing the tablo. And it sounds like you got the splash screen asking to scan for the tablo. It sounds like you need tablo support to get your tablo to a point where it asks to update the firmware. I always use on chrome on windows for that. It’s much easier to determine just what’s happening.

Well on this computer, can you please make sure you can even ping the Tablo directly? Enter the local IP address of the Tablo in Chrome and you should get a page that says “Nuvyyo Tablo Server”. See the screenshot below. If you don’t see this then the computer cannot even ping the Tablo device locally and there is some networking issue.

The local IP address of the Tablo will be able to be found under the configuration pages / status pages of your router. It should be in your case.

Thanks for the replies.

I’m able to reach the device via browser:

Here’s a port scan from a PC on my local network:

And here’s the error, in case anyone reads this in the future with a similar issue:

Did you ever get a response or fix to this? I have the same issue.
I can use the Tablo from my Roku just fine.
the tablo and the Roku are on the same physical switch.
Any other device on my network cannot talk to the tablo.
All my devices are on the same Class C subnet. There are no firewalls between the tablo and my devices. but the devices are on two different physical switches.
I do get to the Nuvyyo Tablo server screen with a browser, and can ping the address of the server.
Can someone tell us what is used to discover the Tablo?

@pacampora The Roku can use a LAN based method of finding the Tablo’s IP if it can’t find the Tablo’s IP on our server. can’t work this way, so it has to be able to find your Tablo via the Internet. It sounds like this is where things are getting murky.

Can you try getting the Tablo directly to the router - temporarily, to see if it allows the Tablo to be discovered and connected to from other apps?