My Roku remote suddenly quit turning TV off & on

This may be a Roku or Samsung question - sorry. Just asking if anyone else had this problem.

I have a Samsung smart TV(maybe 4 years old) and a Roku gaming remote (RCO3). Been using my Tablo Quad with it since installation for over 4 months. A couple of days ago (April 3-4 ish)the remote quit turning theTV on or off. I get an error message “Your TV needs to enable CEC Control for this feature” and refers me to the Roku site. Again, it worked for the 4+ months.

The remote batteries are fine (72%).
I followed the Roku site’s CEC set up procedure and verified that the CEC setting was enabled.
Then tried the “Roku remote set up for TV control”. It tells me that “The current remote does not support TV control”.

WTF? It worked for 4 months.

Anybody else have this problem?

Try rebooting your TV and Roku, by this I mean power cycle them, which may require you to unplug them from the power outlet.

Zounds and Egads!

It’s working again - as mysteriously as it quit.
Perhaps I wasn’t holding my mouth correctly before.
Or, more likely the TV rebooted itself (per User86) after a lengthy time out.

I never seem to have ordinary problems
Anyway, it seems my issue is corrected.