Missing some thumbnails in a show


#1

Setup-
4 Tuner Tablo, Version 2.2.18, 2 TB Hard Drive 1.5 TB Free.

Problem - In fast forwarding through shows we will sometimes encounter grey boxes where thumbnails should be. It is not specific to any particular show and though it doesn’t always happen it seems to be in increasing frequency as of late. I have rebooted the Tablo to no avail. Mind you there will be a stretch of no thumbnails then they will start again. The number of grey boxes is somewhat random in length at least 3 but no more than 6 in a stretch. I would say this is fairly recent (like since the last one or two upgrades?) We hardly ever have 3 tuners running never all four. If you start playing in a grey box it plays fine, if you back up to a previous grey box it plays through the grey boxes without any problem. Also we are usually watching the show that was DVRed the next evening so plenty of time to generate the thumbnails. Any ideas? Thanks - Greg


#2

It’s a known Roku Tablo app problem.
The preview thumbnails actually exist but aren’t being displayed.
You can verify this by exiting out of the recording playback, resume from the same point, and the missing thumbnails will appear.
Tablo Support said it was an issue with the Roku running out of memory.


#3

Not disputing this but, if that’s the case, why does it happen so often during every show? My Tablo operates with the Roku 3800X and has blank fames numerous times during a playback that these frames just come and go! If it’s a known issue why hasn’t Tablo fixed it?


#4

Thanks Radojevic, I agree with lgb62 I hope Tablo chimes in and gives a ETA on a fix for this. Luckily I have a shield that I can switch to. Hopefully they have a better interface than the last time I tried it.


#5

Since it’s not realistic to expect Roku to make a fix on their end just to support a single app that has an issue, it has to be considered an issue for Tablo. If it’s a memory issue related to the caching of the thumbnails, I would think a solution would center around shrinking the size (storage/quality) of the thumbnails.


#6

The blank preview thumbnails issue began when Roku OS v8.0 came out.
Flip a coin to decide who to blame: Roku, or Tablo.
I choose Roku.


#7

With the latest Roku update today, 8.0.0 build 4184, the empty frames have gone away. So I guess Tablo support was correct when they said it was a Roku problem and the next update from Roku should hopefully fix the problem. Check off another problem gone!


#8

Good to hear. My aim wasn’t to assign blame, just that when you’re using someone else’s platform for your app, the burden is going to be on you to work around their issues on most occasions. Ask iOS developers :slight_smile:


#9

Interesting but my Roku Ultra’s, 4670x, are running 8.0.1 Build 4090 and they still lose frames on fast forwarding. I just work around it. I don’t know why the 4670 is running a different software version but probobly because it has a very limited voice command and a good volume control for the tv. I am upgrading my Roku 3 to 8.0.0 build 4184.


#10

When Roku updated their software there were several other problems that were occurring. Tablo came up with work arounds for most of the issues, including the most serious was the Roku playback locking up. Until Tablo installed their work arounds, you would have back out of the Roku app or reboot the app to continue viewing the recording. They were able to work around the most serious issues. The blanking preview panes were minor compared to the other issues.

If this resolves the issue with 8.0.0. I hope they apply the changes to 8.0.1.


#11

You know, its a mystery me about some of these problems. I have 2 Roku 3s and we use both of them every day and we have never had a lock up. Sometimes I think these problems are much more complex that we think. Cheers, J


#12

We even did a lot to reduce the amount of blank frames…

The main issue was that the Roku was using MUCH MORE of its working memory than previously so it would actually run out of enough to show the previews, especially on longer recordings.

Exiting out of the recording and starting playback again usually will free up enough working memory to get them back for a bit.


#13

My Roku 4 with the same OS you mentioned, v8.0.0. build 4184, still displays blank preview thumbnails.


#14

Agreed. My Roku 3 was great last night but missing preview frames this afternoon.


#15

I appreciate Tablo doing as much as they could from their side.


#16

update: The first 3 or 4 recordings we watched had all the frames. Now the last 3 or 4 have had a few blank frames but MUCH better than before. Sooooooo


#17

My 30 minute recordings tend to display most or all the preview thumbnails.
My 60 minute, and longer recordings tend to display blank preview thumbnails.
The longer the recording, the more blank preview thumbnails.


#18

I signed on to say the same thing. Not as many as before the latest update, better.


#19

Well, since I’ve got 8.0.1 build 4190-55 I can vouch that it hasn’t fixed the blank frame issue!


#20

In my opinion, after last update to 8.0.0, the missing thumbnails are worse on build 8.0.1 now than build 8.0.0. I passed this on to Roku and they said there are no issues with build 8.0.1, that the speed of the Roku Ultra takes care of this issue.

My question was, “Were they going to apply the changes to build 8.0.1 that were applied to 8.0.0.”