Issue watching episode while still recording - 4th Gen

So I want to start off with a little background first before describing the issue I had last night with my gen 4. Also I am hardwired into the router and using the Roku app.
The other day watching an older recording I had, towards the end the video froze but the sound kept playing. I hit rewind and play in quick succession and it then continued on without any issue.

So now onto the issue last night. I was watching a show about 40 minutes behind the live broadcast. I watched most of the show without issue, skipping commercials. As I got later into the show the video froze like last time and the sound kept playing. So I tried the same trick of a quick rewind and play, but it then jumped to almost the end of the program. So I rewound all the way back and it did the same thing, the video got stuck and then it jumped to the end.

I am ready to cancel my paid tv subscription, but I can’t till this is working more reliably. We ended up switching back to the paid service and watched the recording there.

1 Like

I am experiencing the same issue, but I have a Chromecast with Google TV.

If we watch live instead, the video doesn’t freeze but it either buffers frequently or drops video frames.

The 1.0.7 update seems to have improved this issue.

I take it back. We ran into this problem again even with the latest software version.

@TabloTV, is this issue being investigated? Watching while recording is simply unusable.

1 Like

I know this doesn’t help you, but I haven’t seen this issue since I got rid of the Chromecast HD’s. We watch the news this way on the 4-tuner 4th gen Tablo every night to dodge the commercials. Start about 15 minutes later than the news starts, then I can fast forward through the commercials. Always works.

Now down to specifics…I did have similar problems (video freezes, audio keeps playing) with the Chromecast HD. The Chromecast 4K that I have works well, though. My theory is that the Chromecast HD is underpowered for the MPEG-2 transcoding.

The other devices that are working for me are some Roku Ultras (4802RW and 4801RW). I think that these are the latest Roku’s.

I’m assuming that Tablo will be able to fix their Roku app so that more Roku devices work well…and will add the Apple TV app as well. But I don’t think that they can fix the Chromecast HD.

In my case, streaming channels are unaffected. Playback after pausing is also unaffected. Both of which rule out an inherent deficiency with Chromecast HD. Even if that were the case, Chromecast HD is an officially supported streaming platform for use with 4th Gen Tablos. So either way, Nuvyyo is on the hook to squash this bug one way or another. All that’s needed to reproduce it is an antenna and Chromecast HD. I opened a ticket with support last week but have yet to learn anything helpful. The most recent correspondence claimed one of my Chromecast HD devices has only moderate WiFi signal reception which somehow points to a pervasive flaw in my home network that is ultimately responsible. Really? That person is either high, still in high school, or both. I swear if I don’t get an intelligent response soon, I’m going to cash in on their 12 month warranty and get an AirTV from sling.com instead.

The HD isn’t as powerful as the 4k model, plain and simple. Many lower devices are “supported” but they will never work as smoothly as a better, more powerful device.

I agree that you shouldn’t have to upgrade your system to make one new device work, but the Tablo uses a little more data and processing speed than what a “streaming” app uses.

If you’ve got some CCwGTV HD that are working and one that isn’t, it would be important to figure out what’s going on with the causing you an issue.

It’s not to say that the Tablo is perfect. It’s getting better with every release and overall, I’m much more impressed with it than I was my first couple of weeks. It’s been quite a while since there was an android/fireos update (12/19/23) or firmware update, so I have to hope something will be coming out soon.

I wouldn’t recommend spending $50 on the CCwGTV 4k model when you could try the same with a $20 Walmart onn 4k streaming box. Test it, find out what the issue is, and if it doesn’t work, take it back to the store. Although, it’s always good to have a backup in case something happens to one of your devices – or an app has an update that needs a day or two before it can be fixed.

I hope you find a solution that works without the need to spend a lot of money. The 4th Tablo is worth – I’ve purchased 3!

Tech Support will always recommend checking networks, and likely continue to suggest that any device connected wirelessly uses 5g. A network reboot does fix a lot of issues and although it’s the most troubling to do (it sucks for those 5+ min while nothing works) it can help in a lot of situations.

Out of curiosity, are you using the internal drive in your Tablos, or are you running off of an external SSD or HDD?

Playback of an episode that’s fully recorded works fine. Therefore, I don’t understand why the processing power of the Chromecast is in question unless Tablo is re-encoding video after the show ends.

What are you using for storage space? Internal or external? If external, what type?

Thank-you for your interest in my post.

Sorry, I was referring to the extra streaming channels within the app. My other ‘heavy’ apps like Kodi and Steam don’t seem to have any trouble.

I can personally attest that it does not happen on FireTV (later returned), Roku (my Old TV), or Android (my phone). Of course, it happens every time on the Chromecast.

As much as I’d rather tweren’t so, this device doesn’t deliver the DVR functionality it claims to provide… so far. Rewinding live OTA television is universally expected of a TV Tuner/DVR. I initially purchased the sling device too for a side by side comparison. I’m beginning to feel like I made the wrong call.

The AirTV is only $20 more, comes with four tuners, and a fully functional app to match!

Just the Tablo dear.

If you look at the progress bar when starting any recording, live OTA TV or FAST station, you’ll see a few differences. Mostly, everything seems to have a bigger buffer/cache than they are permitting for Live OTA TV. Even a recording begins 10+ seconds past the starting point. I’m not sure why these differences exist, but I really think that there could be a bigger buffer set for “live” OTA since the MPEG-2 video is a bit too much data to throw when you’re both “recording” onto a drive (the time shift that lets you rewind) as well as trying to stream/play it at the same time.

It sounds like these are similar issues to what users of older/underpowered Roku devices experience: The need to pause for a few seconds to build a little cache so that there isn’t so much buffering.

I asked about the hard drive because I was previously using a non-recommended device and I had a heck of a time with 1080 OTA video – needless to say it was virtually impossible to play one thing while recording another!

I can only recommend that you keep trying and see what works, hopefully, there’s a better work-around than pausing to build up that buffer!

It sounds like every other device has worked in the past, so there’s got to be something with the HD CCwGTV. I recommend downloading Background Apps and Process List to see if there are a lot of apps still loaded in the background. Maybe closing them and a fresh reboot will help clear up some of those issues.

Sadly, it looks like they were able to lower the price so much on the HD because of how different the processor speed and RAM are between that and the 4k.

Good luck and keep us posted.

My comment about the Chromecast HD being under-powered is simply based on the fact that when I tried to watch a show that was being recorded the video would freeze and the audio continued to play. This has never happened with the Chromecast 4K, which I’m using every day now. Since the way that I watch the news every night is to watch it while its recording, and the Chromecast HD failed every time that I tried to do that, they didn’t last long here…a few days was all it took to establish a consistent problem. Since I had a couple of other working platforms, I didn’t need to keep a consistently failing platform around.

I also noticed that the Chromecast HD was slower at UI actions, like the initial setup and after that, bringing up apps, than the Chromecast 4K. This was another indication to me that Google had skimped a bit with their HD hardware.

1 Like

These specs really say it all.

I have this same issue (video freezes but audio continues) when using my 4th Gen through my Chromecast 4K on an LG smartTV to watch while still recording. I do not have the same problem on my Roku TV or using the Roku Streaming stick on a 3rd TV. I only use the Chromecast because the Tablo app on the LG content store doesnt support 4th Gen. Any clue when either of these (chromecast timeshift or LG support) will be resolved? Both seem like large enough user bases for Roku to care.