Is anyone else not getting prompted for the firmware update?

Had the same issue with the .12 version.

Just submitted a support ticket.


I’m new to Tablo but I am at 2.1.24.  Is sthat the latest or should I be receiving an update?

2.1.24 is the latest.

I have the same problem. I waited for a less busy recording period to update my Tablo to the latest firmware but now that I want to do it, it doesn’t prompt for the firmware update. I guess I’m stuck at 2.1.20 for the time being.

@sgnadeau, my 2-tuner unit is still at 2.1.20, but I received the update to 2.1.24 for my 4-tuner unit.  I even did a reboot on the 2-tuner, but that didn’t force a firmware update prompt.  Fortunately I am not having any issues with 2.1.20, so it is not a problem.


.24 has the cool thumbnail preview though. Contact TabloSupport if you still haven’t been prompted to upgrade.

My dual tuner got the update the same day.

I was never prompted, I had to choose the update button, then it found the update. Nothing automatic about it, I had to know there was something out there, go into settings, choose update. 

I’ve seen a lot of “not prompted” quotes here, but nothing about “clicked the update button and it didn’t find anything”  - so it’s hard to tell - are folks sitting back waiting for their Tablo to TELL Them there’s something out there, or are they using the update button and it’s not finding anything? No one has been real clear so far the process they are using…

The Update button on the Settings page is no longer there.

I had the prompt to update to 2.1.24 and then a day or two later it was for 2.1.25. When I tried updating the firmware during the weekend, I got a download error. I tried twice to update the firmware and I was getting the same download error. After that the prompt to update and the update on the Settings page disappeared.

When saying I was never prompted, I mean the update button never appeared in the settings page.

@JCmontreal Pretty weird. We’ve already arranged to set this up privately, we’ll take a look while we’re upgrading your Tablo to see why it wasn’t receiving the prompt.

I installed new Tablo (2 tuner) 2 days ago. Has version 2.1.10 ---- I do not receive prompts to update the firmware. What do I do?

Are you sure it’s not Tablo firmware v2.2.10, cuz that is the latest production version.
If your Tablo really is at firmware v2.1.10, then you’ll eventually get prompted when connecting to your Tablo via a web browser, like Google Chrome (preferably), at
If you have a Roku, the Tablo app will also prompt you to update the Tablo firmware.

Thanks…mea culpa, it is 2.2.10

You are forgiven. :wink: