I think I found a bug

I think I discovered a bug in the Tablo.

I had scheduled to record Instinct on Sunday night from 8 PM to 9 PM. Then at 8:15, I realized that the show had not started on time, because 60 Minutes was still airing. So I went to the show’s recording options and extended the end time by 1 hour. To clarify, I extended the recording’s end time while the the show was currently being recorded.

Later that evening, I checked to see if that change took effect and I thought it did, because it said “Recording Now” when viewing that show in the menu.

Then on Tuesday night, I checked again to see if the show recorded correctly and it still said “Recording Now.” I thought “Holy crap! It’s been recording for two days straight!” But it wasn’t really. Even though it still said “Recording now,” it only recorded one hour. So, changing the recording end time while the show was being recorded did NOT work and it resulted in this weird bug. Seems benign enough, but that’s not all.

I went to the Scheduled menu and selected the show. That episode was still listed as an upcoming scheduled recording. I tried to reset the end time back to the default, but the changes would not take effect. In fact, I wasn’t able to change the end time of any shows.

Later I discovered several other issues. I noticed that the Tablo failed to record anything after Instinct. I was able to watch my Tablo recordings on my ipad, but it would not sync (so Instinct was never listed in the menu) and for over a day it continuously said “Updating Guide.” Meanwhile, I was not able to connect to my Tablo using a web browser. It just said no Tablos were found.

After unpluging my Tablo for 30 seconds, everthing worked fine again.

In summary…

The cause: Changing a show’s recording end time while it is actively being recorded.

The effect:

  1. The change to the end time does not take effect.
  2. The episode continuously says “Recording Now” when it really isn’t.
  3. Afterward, any changes to the end time for that show or any other show will not update.
  4. No other shows will record and there is nothing to notify you of the failed recordings.
  5. The iPad app won’t sync and continuously says “Updating Guide.”
  6. You can’t connect to the Tablo though a web browser.

I’m going to try to replicate this bug again during daytime television this weekend, when I have time and won’t care about failed recordings. By the way, I’m using a Roku.

Nice find, particularly if it’s recreatable and nice write-up regardless.

Only thing I would suggest is it seems like a very specific scenario so even if you can’t attempt to recreate it until this weekend you might go ahead and submit a ticket ASAP and get your Tablo in remote access mode so they can grab any relevant logs before it’s been too long and they are no longer available. I bring this up because I ran into a similar situation not long ago troubleshooting reception issues where by the time they were able to remote into my Tablo the logs were no longer available and nothing useful could be found.