How to migrate to a bigger drive?

I just stumbled across my old about the possibilities of recovering shows from an “off-line” drive aka dead/no tablo. Here’s and updated post I have regarding the topic… if by chance it helps anyone someday -

I put off my attempt for a number of months, but am now able to report success moving my recordings from an external drive on my old 4-Tuner to an internal drive on my new Quad.

First, I tried to move over the external drive ( ). This failed, partially, because I didn’t reset the 4-Tuner at first to copy its database. Thankfully, Tablo Support was able to fix that for me by running some sort of maintenance script on the Quad after I gave them remote access.

After that, I powered down and attached both old and new drives to an old Dell running Knoppix (bootable Linux). I was able to use the tool to copy the ext4 partition from one drive to the other. The new internal drive (an SSD) worked in the Quad as though nothing had changed.

The copy was made easier because a) the new drive was preformatted by the Quad thanks to earlier, failed attempts, and b) it was exactly the same size as the old drive. I suspect neither of those were strictly necessary, but can’t be sure.

1 Like

Thought I would share that I was able to use this approach to migrated to a bigger drive this weekend. Had some initial trouble that I am now chalking up to a bad USB cable. Once I figured this out, it was pretty easy. Because of some of the concerns about Ext2FSD on Windows 10, I pulled out an older laptop running Windows 10 Home instead of using my primary PC. I downloaded the 0.69 version of Ext2FSD. I connected the old hard drive using my good cable. I was able to assign a drive letter in Ext2FSD and then copied the contents of the REC folder over to the Documents folder on my laptop. Then I removed the old hard drive and connected the new hard drive which I had already connected to my Tablo Lite unit for formatting. I assigned a drive letter and then copied everything over to the new hard drive’s REC folder. I flushed the cached data per instructions, then reconnected to my table unit which was powered off. Powered it up and had everything that I had copied over. Thanks for the instructions. Worked great.

I am trying the BabbleBits procedure from post 6/123 using Ext2Fsd and am stuck at the above step.

Im not able to view the contents of either source/destination drives using Windows Explorer. The drives and letters are there but when I try to expand the contents of either of the drives, Win10 Explorer throws a popup telling me I need to format the disk before I can use it.

I do see there are /pvr directories having the REC directories inside them via Ext2Fsd, but the utility does not seem to allow any copying.

Any ideas what I may have missed ?

I punted on the Ext2Fsd.

I was able to download the Paragon Software for EXTFS on Mac to successfully copy over the /rec
directory entries on the 1Tb WD Elements drive to the 5Tb drive. The Free 10 day trial accepted all usage capabilities from what I could tell. This was about 931Gb of material and it took all night. Both USB ports and drives are 3.0 but I suppose my transfer speed was limited by the read speed of the older 1Tb source drive.

FWIW, this took about, and im guessing, 8 hours to do the copy.

My Macbook was limiting how many objects I could copy as a group, and overall performance through the Mac-Finder was very lethargic at best in trying to instigate the activity.

The easiest way to do this is to open two finder windows side by side, one for each drive and drag from one side to the other. Just dont forget to “mount” both drives and test a drag/drop of a single directory object before you increase the size of the group of objects you are transferring.

When you believe you have completed the entire copy, I recommend you compare the number of objects and the sum total of the space of the objects to validate nothing was missed anywhere.

Direct documentation related to this exact process is scant so you will may have to fumble around before you see what works.

I just plugged in the new drive… my random selections of recording play. The Tablo App seems to be operating normally. I’m Good !

Good luck to those looking to walk down this same path.

I successfully completed the transfer of 1.9 TB of programs (2,607 file folders) from a 2.0 TB Western Digital Elements, to 5.0 TB Seagate using BabbleBit’s 14 step procedure listed in his Jan 2015 post. It took a long time, about 60 hours total, but it worked! If I were to do it again, I would make sure I was using a computer with two, USB 3.0 ports. My little Lenovo Yoga 2 in 1 laptop (Windows 10) only had one 3.0 port (and one 2.0 port). Below are the pertinent details to my transfer. (These are in addition to the procedure from BabbleBits.)

  1. Adjust Power options so that the computer shutdowns “Never” as long as it is plugged in to power.
  2. Disable the WiFi (and/or Ethernet cable) to prevent other programs from accessing the Internet. (My first copy attempt shut down after about 7 hours (target drive disconnect). Fortunately I did not lose the files that had been transferred before the disconnect. I speculate that the computer was getting overtaxed – maybe Windows trying to download an update – so I decided it was best to shutdown the WiFi, and didn’t have the disconnect problem again.
  3. Used an ANKER 10 port USB 3.0 hub plugged into the computer’s 3.0 port. (I tried various options of plugging the drives directly into the computer, one in the USB 2.0 port and the other in the USB3.0 port, and there was no apparent speed difference so I left the hub plugged in so I could use the wireless keyboard and mouse that were connected through the hub.
  4. Plugged the target drive into the hub first, assigned drive letter. Then I plugged in source drive to hub and assigned drive letter.
  5. After the first disconnect problem described in 2 above, I selected blocks of 500 file folders (~350GB) in the “rec” folder source drive and copied to “rec” folder target drive. It took about 12 hours to copy the 500 folders. (For most of the transfer I was getting average rates around 10 MB/s – yes, it was very slow.) Repeated until all of the 2,607 folders in “rec” were copied to the 5.0 TB drive. (It was interesting that the last two blocks of 500 folders copied at a much faster rate. The last set of 500 folders (390 GB) transferred in less than 6 hours. Don’t’ know why – perhaps less fragmentation on the disk?)
  6. Lastly I also copied the folder “db” from the source drive to the target. There wasn’t a like named folder on the target drive when it was formatted on the Tablo.
  • When I was about two thirds finished, I tried using a friend’s new Windows 10 desktop with two USB 3.0 ports to speed things up. Unfortunately after installing the Ext2Fsd program, the two Tablo drives showed up as EXT3 instead of the EXT4 that my Tablo formatted them. Windows did not recognize the drive and prompted me to reformat the drives. The problem was probably related to a compatibility issue with the Ext2Fsd program and the new computer. I didn’t attempt to troubleshoot and went back to my Lenovo Yoga to finish the copying.

Again, all worked normally when I plugged the new drive into the Tablo. All the recordings were there, and I now have 3TB of free space! Thanks to BabbleBits for the great instructions. After seven years it is still a great reference!

1 Like

Thank you for the Informative step by step.

I’m not sure if this will help, but this is what I am doing today. I’ll let you know how everything works out.

I’m a Linux user. I currently have Ubuntu installed on my PC. These are the steps that I took to access the files with sufficient privileges to copy them to the new drive.

  • Disconnect the old drive and connect it to your computer. Computer will recognize and mount the drive.
  • Connect the new drive to your Tablo
  • In a web browser, navigate to You’ll see that the Tablo recognizes the new drive and is prompting you to format the new drive. Follow the instructions and let the Tablo format the new drive.
  • Disconnect the new drive from the tablo and connect it to your PC. Your PC will recognize and mount the new drive.
  • Open a terminal window and run “sudo nautilus” … without the quotation marks … to launch the nautilus file manager with root privileges.
  • Determine which mounted USB drive is the old drive and which is the new one. That should be easy. The rec folder will be empty on the new drive and it will be full on the old one.
  • Copy all sub-directories under rec from the old drive to the new one.

I have a ticket opened with Tablo on the issues that I’ve been having. I’m losing HDD connection daily. I ran a few utilities on the old drive and it does look like it has some bad sectors on it, so I bought a replacement drive. I’ve sent email to the person who has my ticket asking if other directories need to be copied over or if simply copying the rec directory will be sufficient.

I’m a Linux user

The following advice may come too late for you, or may indeed be unnecessary. Do let us know how it goes!

  • I found it important to reset the Tablo at the very beginning of the process, before disconnecting the old drive. This copies the Tablo’s internal database to the drive, which may otherwise be out of date, but may not be necessary if you are keeping the same Tablo rather than moving to a new one like I did.

  • It would be best to image the entire drive. I used when I did it. I don’t recall the directory structure & whether the database is inside the rec folder or not.

  • Failing that, rsync would be better than “copy all sub-directories”, so as to entirely replace what’s on the new drive. At least do Ctrl+h in Nautilus so you can see if there are any hidden files to copy.


I took your advice and stopped the copy process. I put the old HDD back on the Tablo and reset it. I tried to copy the data from the old to new using gparted, but the old drive stopped responding. I took it out of the USB enclosure and removed the USB interface and installed the drive into my computer. I’m currently in the process of copying the partition using gparted. It’s been going for a number of hours now without any issues. Still quite a while to go, but it’s looking better. I’m thinking that the USB interface has gone bad and that was the cause of the issues I was having with the Tablo losing connection to the HDD.

Thanks for the advice. I’ll post here again once the copy has finished and let the forum know how it went.

After about 30 or so hours, looks like I’m back in business. gparted skipped a number of blocks on the old drive with an I/O error - unable to read data in block. I’m not sure if any issues will show up as a result of that, but so far so good. I’ve connected the new HDD to the Tablo and it looks like everything is there and the recordings that I’ve selected have played just fine.

I reset Tablo then disconnected the old HDD from it. I removed the physical disk from the USB enclosure and installed it into my PC. I then connected the new USB HDD to my PC, launched gparted and copied data from the old HDD to the new one. I then connected the new HDD to the Tablo and reset the Tablo. Easy peasy. Like I said earlier, it took over 30 hours for the copy to finish.

That’s how I do it myself. The extra time it takes to remove the drives is more then made up for by the extra speed when dealing the big drives although it’s likely I will not transfer contents to my next drive because the files I want to keep are already backed up to Plex.

I’m surprised I haven’t heard of anyone creating a bootable USB or a RPI image to facilitate the data transfer. It would be the simplest possible solution for most people. Particularly a RPI4 with USB3. For around $50 all in that would make a nice standalone device to transfer the data. The transfer takes a long time over USB so you might not want to tie up a laptop or PC for 2 or 3 days. lol

EDIT: Probably $60 all in due to chip shortage price increases.

Or you can use one of these. It will do a copy sans computer. I’m not sure if you would need to extend the partition after the copy to take advantage of the additional capacity.

I used

an old Dell running Knoppix (bootable Linux)

1 Like

Way easier then the recommendations we often see for people to do it on Windows!

One big issue that I was having when I tried to image the old drive to the new one USB to USB was that when gparted encountered a bad sector on the old drive, it would time out and the imaging would be halted. Once I installed the 5TB drive into the computer, when gparted encountered a bad sector, it would halt, but eventually skip that sector and move on. I’m sure that I’ve lost data somewhere, but I haven’t had any issues with the new drive on the Tablo yet. It’s been several days and I’ve been DVR’ing quite a bit. The Tablo has not lost connection to the new drive and I haven’t had any issues with playing back old recordings - yet.

On the plus side, I have a 5TB drive installed in my computer and now have a backup routine scheduled weekly for my EIDE raid enclosure. The drives in the raid enclosure are aging too. I’m thinking about replacing them as well, so it’s nice to have a drive large enough to hold all of the data on the raid enclosure just in case.

I stopped using Windows many years ago. I purchased a full version of Vista. The computers that I had at the time were incompatible. I found that out by installing it on my laptop and using the registration key on it. While the installation failed, the registration key had been used so when I eventually purchased a computer that was compatible with Vista, the registration key failed. MS insisted that since the registration key was good for only one installation, they required me to purchase a new key. I felt that to be obscene, so I wiped my HDD and installed Ubuntu. I haven’t looked back.

1 Like

That’s weird. Usually you can move a registration key. Either way Linux definitely has it’s perks!

The Tablo recordings are broken into chunks. I’m not sure what happens when a single chunk is bad. It might just skip that chunk and there is an approximately 25% chance the chunk is just a commercial anyway.

I tried what you suggested, but my Windows 10 workstation wants to format the drives after I assign drive letters. How do I avoid that?

I followed the instructions from BabbleBits and it worked flawless.

changed a drive for an DUAL HDMI model using a fast window 10 and USB 3.1 ports. Found a free version of Ext2Fsd program. Took about 30 seconds to copy an 1 hours of recording.