How Robust is Remote Connection

OK, I bought a refurbished Tablo Dual Lite.

Sharing a few of my experiences so far.

  1. If you buy a refurbished unit the subscription free trial has already expired.
  2. To do set up you have to use Chrome or Safari or Edge browser. Firefox doesn’t work.
  3. Tablo tech support is awesome. Very friendly and very helpful.

I set the unit up at my house to learn how. From there I tested the remote connection which worked perfectly.

However, since I don’t get all the local channels at my house I am going to redeploy the DVR to my son’s house. I still have slingbox as a back up in the meanwhile.

So, then I will start a long term trial and see how long and reliable (robust) the connection is.

Discussing this with Tablo’s tech support he indicated the problem with losing the connections (barring something going wrong with the remote device) was due to the router on the LAN where the Tablo is set up changing IP and port addresses. Lots of variables there but he felt worst case scenario was those could be locked down manually.

I am inferring the UNPNP on some routers, but not all, may change port numbers of its own volition. And routers that require manual configuration (don’t have UNPNP) probably don’t have this problem.

In short, I am optimistic the connection can be made reliable if it isn’t that way to begin with. But we’ll see what happens.

I will let you know as this progresses over the next year (if anybody cares).

Hey there - If you purchased your Tablo from us you should have recieved a 30-day free trial. Drop us a line and we can get that sorted out for you: www.tablotv.com/ask-tablo/

1 Like

I can’t say remote connection is robust on iOS. I’ve used the iPhone 7 and I’m now on an XR every few weeks the connection is broken, usually when I need it most like today during a Washington football team game. The connection needs to be reestablished on the home network pretty much every month. Can I trust it any more on the fire stick if I were to, say, take a connected one out of the country?

Nuvyyo has simply got to solve this issue once and for all, perhaps with account authentication.

I am still assessing this situation and can’t guarantee I totally understand it.

But talking to Tablo tech support it appears the external port assignment ( the port the remote device uses to access the Tablo on the home LAN) is crucial.

If you have an older router and don’t have dynamic allocation you have to manually map the port. This is my current situation and it has worked for a couple of weeks so far. And I think it may work indefinitely because the router doesn’t have the ability to reallocate the ports.

But, if you have a newer router that does have dynamic port allocation that router may change the port assignments of its own volition. And this is why you may be losing your connection.

Different routers may have different drivers, or parameters. Maybe some routers with dynamic port allocation never change the port assignments, whereas others do for whatever reason.

So, on those routers it may be possible to manually configure the public port Tablo is using and lock it down which may solve your problem. Right now I don’t have anyway to test this theory.

Maybe you can check you port assignments at the time you pair your device, and compare them to after you lose your pairing,

If anybody thinks, knows, I have an incorrect understanding of the situation please let me (us) know.

Good idea to take note of the ports and see if anything changes when connection breaks. I don’t think my trusty old Linksys WRT is capable of changing the ports though (see below).

I wish Tablo would chime in here if they believe there is a common thread that we should be looking for. I’d also appreciate a cogent explanation as to why they can’t implement some sort of authentication scheme for the connection. Is it just too technically difficult?

This shouldn’t happen even if UPnP is enabled on your router.

I have an iPhone XS Max and I’ve gone months, maybe 6 months with the remote pairing working, always able to connect. Why 6 months and not longer? See below.

When I upgrade my iPhone I do not do an OTA update, I connect it to my computer and “restore” the phone to factory defaults (old habit from jailbreaking days). When I do this and have to re-install the Tablo app, my Tablo is not even in the app (which is expected and normal behaviour).

1 Like

OK. Like I said, I have only had my up and running for a couple of weeks now.

And port shifting apparently wouldn’t explain allegator1’s issue.

Just as an aside I’m not a big fan of Apple. Maybe it’s because my wife is…

And, I also agree the so far very agreeable and very helpful, for me anyway, Tablo tech support should be assisting.

I was laid off from a very large company in July. Their product support database could be scanned to look for trends. Similarly, you would think Tablo’s tech support could offer better insights into this.

And, I too would prefer simple remote login and authentication versus the pairing arrangement. So far the Tablo has been pretty much superior to my slingbox in every was except for that.

I am going to ask Tablo tech support to read this topic.

I recently purchased a refurbished Tablo Quad and was interested in the remote connection as well. So far my setup has worked fine but I tried to statically configure as much as I could to eliminate anything from changing. For example, I configured a DHCP reservation for my Tablo in my router so that it’s IP shouldn’t ever change. Even though my router supports UPnP, I configured static port forwards to my tablo in my router as well. I guess time will tell if I will have any issues but so far so good.

I asked Tablo tech support the following 2 questions.

“One person there (allegator1) says his router doesn’t have UPnP and he still loses his connection.”:

The UPnP functionality on a router can be a possible cause of remote connection issues, but it is not limited to just this one feature. The Tablo’s public ports are being assigned by the router, and every user’s network is different, which means the possible causes of such issues will be different depending on the user.

“Also, I too wonder why you can’t just have login and authentication to a given device.”:

Other streaming apps (Hulu, YouTube, etc.) usually have a remote server in the Internet and you can log into your account and download the data from the Internet. With the Tablo, you can think of the “remote server” in this case as the Tablo DVR inside your home. You’re not receiving the main data from a remote location from the Internet, but it’s coming from inside of your home - this is why the appropriate ports need to be forwarded in order for your router to allow external clients access to a device (in this case Tablo) on a private network.

I also asked them to look at this thread.

OK, it’s been a month since I set up the Tablo dual lite at my son’s house (where he gets most of the OTA channels) so my wife and I can watch tv at our house (where we hardly get any channels).

So far the remote connection has been rock solid with our firesticks and and fire tv. No issues there.

Issues I am having are:

1st, wish there was a way to keep the tablo from starting with a “playback error”, “retry” or “cancel”. This can, and does, sometimes lead to the tablo app giving a blank screen, the colored backgrounds for the menus are there but there’s no text, and/or the tablo not being able to find the connection.

So far this has been fixable by clearing the cache in the tablo app, forcing the app to stop, and launching the app from the firestick settings. I can do this, my wife can’t (or won’t even try).

2nd issue is buffering. Most of the time, 95%(?) the tablo works fine with some intermittent but very minor buffering. Sometimes it will just stop working, buffering so badly, it becomes unwatchable. This can last for maybe 10-20 minutes and then it goes back to normal.

I have very good internet as does my son who works remotely as a programmer. I checked the connection speeds at the receiving devices and it’s fine. Everything else, Netflix, slingtv, slingbox, works fine.

The only thing I can come up with is Tablo is being throttle either by our ISP (Ziply) or my son’s (Comcast).

Anybody have any comments or ideas on this?

Thanks.