Horrible experience

New Tablo user, 2023 version, connected by ethernet, have had nothing but trouble for the full week I’ve owned it.
I’ll go to the live guide, and some channels are blank.
The channels don’t even lineup with the programming, you have to actually click the channel above it to get the channel you want.
Other channels, you’ll click to play, and it’ll say “playback failed, retry?”over and over again.
Or it’ll bounce you back to the home screen.
Customer service is a disaster, long wait times and an automated system that lies to you about how long the wait time will be.
Asked for a supervisor, I’m told all they do is email you back but of course they never do.
Actually got a phone agent today who blatantly hung up on me, then ADMITTED she hung up on me when I got her on the line again.
Then she told me all the problems I’m having are a “known issue” and it will take “weeks” for them to even investigate, much less fix it if they ever do.
Have uninstalled and reinstalled the app three times, and rescanned the channels four times.
Getting all these issues on multiple Roku TVs.
Should I just give up?

1 Like

“Or it’ll bounce you back to the home screen.” On a gen 4 this might happen if at scan time there is a signal but when played the signal quality is too poor or nonexistent to play.

You could try the trick I saw in some other thread. Remove/delete all the channels except 1 FAST channel. Then reboot the unit. make sure the Live grid only contains the 1 FAST channel and then re-scan and slowly add the channels back in. There are probably going to be some non-playable channels in the scan list.

Low power OTA stations may not supply a guide. Or a different zip code might have the guide

1 Like

Hi there, we’re sorry to hear you didn’t have the best experience with our support team. We’re currently dealing with higher than normal call volumes, and as a result some wait times are currently higher than normal.

Our team is prioritizing the issues you’ve encountered on the Live TV guide and we’re hoping to have a resolution to these issues soon.

With regards to the ‘Try again’ errors you’re encountering, or being removed from the video player and send back to the Live TV grid - these could be related to signal issues. We only recommend adding the channels with strong signals to your Tablo’s guide.

Our team is still happy to work with you to do what we can to improve your experience. However, please note that our team members deserve to be treated with respect - otherwise they can and will end the call and reserve support to email only.

Did that already, it was one of the “troubleshooting steps.”
Nothing changed.

You mean the same “respect” I got when she hung up on me?

That is standard message for any customer support line anymore.
Translated that means “we don’t care about your problems otherwise we would have hired more people.”


Totally agree, and my issue isn’t that the wait times are long, it”s that the automated system LIES about how long the wait time will be.
Twice in the last week I got an estimated wait of nine minutes that took 27, and another estimated wait of 26 minutes that took 59, and then at the end of that one it went to an automated voicemail that said “we are too busy to take your call now. Try again later,” even though their Support is allegedly open until 2:30 AM each day and it was around 11 pm.
Then, last night, I requested a call back around 11 pm and no one ever called.

Experiment a little with the amplifier. If it is on, turn it off, rescan and check for improvement. If it is off, turn it on, rescan and check for improvement.

The amplifier can cause a very strong chan to overdrive the receiver enough to keep the signal from being properly decoded. Turninng the amp off can often reduce the signal strength enough to reduce the distortion.

A weak/marginal signal can be helped by turning the amp on.

Good luck

Just tried that, no change.
Still many blank channels, still getting “playback failed, retry?” and the channels don’t even line up with the show info, everything is off by a line.
Which means if the show you want to watch has a blank line below it, you cannot click it at all.

See the post regarding incorrect guide data. I believe the fix there might help with your guide data being “off”

It sounds like if you followed the instructions you wouldn’t have added back any blank channels

I didn’t see in your original post that you were experiencing the issue on Roku TVs. I had the same issue with both of my Onn Roku TVs. I unplugged them for 10 minuted and the problem went away after I plugged them back in of course :slightly_smiling_face:

I did not get instructions emailed to me, but I had already done the “deselect everything except one channel” thing.
Didn’t work.

if you still can, return unit. support and fixes are promised but not happening. apple tv been not working for over 5 weeks. i agree with you on support , i had same experience.

1 Like

Thanks, yes I can and will return this piece of junk.
I honestly thought I’d never see a company with worse customer service than Comcast but now I have.

Sorry to hear your having problems with your unit. I had the exact same problem with the guide having blank channels and the other channel descriptions being shifted down from the correct channels. A real mess for sure.

I know you tried the fix regarding rescanning the channels…but you also indicated you didn’t have the email from Table Support with the instructions. Here’s what I did that corrected this problem:

  1. Make sure your Tablo is using Firmware 2.2.46
  2. Uncheck all the OTA Channels except the FAST Channels (must have at least one FAST channel selected).
    Select the Save and Continue option then WAIT 10 Minutes so the guide can update.
  3. Re-Add the Channels to the Lineup by running Recan Channels. Then select the channels you want to save and press the Save and Continue option and then WAIT 10 minutes so the Channels will update.

This should fix the TV you are working on. However, I think you indicated that you had several TV’s with Roku too. To get the other TV’s to work, you need to do the following on those TV’s:

On the other TV, delete the Tablo App by selecting the Tablo App and then press the * button on the remote. Then select the Delete App option. Once completed, reboot the Roku device (turn off then on again)… this is an important step. After the Roku is rebooted, then re-add in the Tablo App. Re-launch the Tablo App and the Guide should be corrected on this TV. Repeat for all other TV’s

I hope this works for you like it did for me! Good luck.

I am using the latest firmware, but it’s not a Roku app.
It’s a Roku smart TV using the Tablo app.

I was using a Roku Ultra connected via the HDMI port on my TV’s. However, I would think the Roku TV is just Roku OS built into the TV instead of having a separate Roku device using an HDMI Port to display the Roku OS.

Adding/deleting the Tablo App should be same as I would would do on my Roku Ultra. Hopefully you will get the same results and fix the problems you are having with the Guide.

The Roku Smart TV is running the same Roku OS that stand alone Roku units run, sometimes they are just on different versions depending on the situation.

I think @gatorgogo meant delete the Tablo app in the first sentence of the second paragraph after the list of steps, the point being you basically delete any “app data” and force it to reload with the corrected guide.

Thanks … I’ve edited my comments to refer to the Tablo App…