Guide missing on all my devices

Just upgraded from the monthly guide subscription to the lifetime and now I have no guide. My account says I have a subscription but none of my devices and my PC don’t pull up a guide. I have tried resetting everything and downloaded new guide data and I’m still showing nothing. Ideas?

Is the grid for the Guide viewable but empty or you can’t even see the grid? If the former, the Guide may be syncing.

The grid shows up and is blank. Left it for a little while and still nothing. I even pulled it up on my roku under the old app and it just has channel numbers and their name but no info on what is actually on.

I think it takes a little while for the grid to populate. Others may be able to provide more detailed advice but I suspect you will see a populated grid in an hour.

It’s odd because when I had guide info it would a take a few seconds to load the channels. Now, it pulls up instantly but loads no guide data. I might just leave it up for a while and see if anything pulls up. If it takes a long time to pull up guide data, like an hour, kind of defeats the purpose of paying for the guide…

I’m suggesting that it may take an initial period of time to bring up guide data but then will be speedy after the first time. Also did you restart your Tablo?

Yeah, I restarted it a couple times. This has been an issue for the last week. I contacted support but no one has responded yet.

Can you try changing your postal code?

I tried that once I had a chance. Do you think I need to forward ports?

This is all I am getting…

Here it is 3 hours later.

Wonder if I can get a refund…

Did you try updating the guide again?? When I initially setup mine I found I had to do that.

Go into settings and update now

@Kaladynn If you’re still missing your guid, please send us a note - we’ll get this fixed up for you.

TabloSupport - What was the fix for this? I’ve had a ticket open (10466) since I bought my 4 tuner Tablo and have yet to even see a guide at all anywhere. I’ve been working with support and have reset, rebooted, factory reset, re-synched, changed drives etc. All I can do on mine is watch live TV on the Tablo app in Roku or on my iPad. I cant even manually record. Kaladynn’s description pretty much mirrors mine.