Guide is different on separate Roku devices

New user here, please forgive if I place in wrong area, etc. Or if I am making boneheaded mistake.

4 Tuner feeding Roku Premier and Roku Ultra. I went through channel list today on laptop, unselecting channels that I didn’t want after viewing on Roku Premier. Saved, updated guide, all is working fine, channels I removed don’t show up.

Roku Ultra is still showing all the channels, including the ones that I removed. I have tried disconnecting / reconnecting Tablo; Removing and adding Tablo Channel / App. The only thing that I haven’t done on the Ultra is to manually update the Guide. Otherwise, everything works as it should, including being able to see the programs that I have set to be recorded.

Roku channel are both 2.7, Tablo is running latest and greatest (2.22?). Both of the Roku are apparently pinging time server via the router per router logs, time is exact between them. Even if Roku update channel and info from Tablo, I would think that deleting and re-adding the channel would force the channel to pull fresh data from Tablo. I have not restarted the Ultra yet as the better half is watching GodFather marathon now. I should have tried that earlier, but didn’t thought didn’t occur. And I don’t want to meet her little friend.

Additional Info: The Premier is a bit better than marginal apparently as far as signal qualtiy from the router. It does buffer, and I will be setting up a wifi extender to address this. Channel List edit was done while using the Premier (biggest TV). The Roku Ultra is rock solid signal. Installation is 3 days old today. I did sign up for Lifetime shortly prior to channel list edit, perhaps that has some bearing as well?

1 Like

No excuses, cuz we’re all perfect here. :wink:

Are you absolutely sure the broadcast channels were deleted?

Do you mean you powered off and on the Tablo, or you selected the ‘Disconnect’ button in the Roku Tablo app?
If you haven’t performed the latter, try it.

Technically, performing a manual Tablo guide update triggers the Tablo to download the latest guide.
It should not matter where you trigger this process from: PC; Mac; Roku; …

As I was thinking of something clever to say, I realized you made a cross-reference to Scarface.
Now I fear for you, and am much happier with my wife. :slight_smile:

I am absolutely sure that the guide was displaying properly. I was able to see the channels were modified on the laptop (Firefox via Ubuntu) as well as on the Roku Premier. Was amazed that my channel count went from 120 to 77. Lots of foreign languages and shopping in Houston area.

When mentioned disconnect / connect, I was referring to operation within the Roku channel, not restarting the tablo itself. Is there a way to restart the tuner from within the setup / configuration page? Hardrive shows activity most all the time, wouldn’t restarting the tuner externally risk a corruption (or worse) event on the hard drive if in middle of write operation? I am able to verify that there is not a recording operation in progress, but there is a lot of disk activity…

I am going to have to table this problem for the moment. I was poking around in the hidden screens on the Roku Premier, and there appears to be something that is going south. Network Signal comes and goes, Antenna 2 is lost, glitch count increments rapidly. Problem is much more pronounced on one router (MBR95) vs an AT&T gateway. Yes, both represent 2 different providers.

I will be defaulting both of the Rokus, and starting fresh with only the bare apps required (vs what the family has installed). I am sure that will earn me some complaints… I think its best to start with basics first, then slowly add bells and whistles and see if I can identify where problem creeps in. There may have been a problem all along, but not apparent since other streaming services have a much lower apparent bandwidth requirement.

And yes, I will be posting the results and actions.

1 Like

Roku Ultra (the problematic one) reset back to factory. Removed all apps that are “preinstalled” including Tablo. Checked wifi/network hidden screen, still have problem. Likely the router itself and/or configuration.

Added the Tablo channel, and is the only channel. “Full” Channel list is being displayed, either something has survived the factory reset, or the channel is pulling configuration data from the uSD and/or the Tablo 4.

The hunt continues.

uSD card wiped and formatted on the Roku. Factory reset the Roku, again. Removed the apps, re-added Tablo. Guide still has all channels, incl. the ones that I had pulled out. Total channel count, 120. Should be around 77. So, Tablo app is pulling from the tuner itself, yet other Roku is displaying correctly.

Going to restart tuner, see what happens. I would be very surprised if this fixes the guide issue, as 1 of 2 Roku boxes, running the Tablo app, is displaying correctly.

The Hunt continues.

Opened portal to my 4 tuner tablo prior to restart, wanted to make sure that there wasn’t anything recording. Couldn’t find any events current, checked the channel lineup, and damn it, the channels are all there. The Roku Premiere, the one that is working, is still showing channels removed (Total of 77). I don’t know what to think now.

This is so strange. It does seem to be leaning now, toward a Roku problem, rather than a Tablo one. I’ve used Premier, Ultra (and older) Roku product, have not seen my Tablo behave any differently, either way. Is your (faulty) Roku a new or recently-purchased one?

Seems like users have seen problems in the past where one set-top-box does not match another.

Could be too many OTA channels or not enough memory due to too many Roku channels. Then there all the problems caused by the speed it took to load the guide for all of those channels.

Well, it gets better. Using WiFi/ network secret menu, my ultra is having all kinds of problems on the mbr95 router. The premier, on sale router, is pretty stable but low signal.

I suspect my Roku Ultra is pooched. Full factory wipe / remove n wipe uSD/ remove all channels has a neglible or undetectable effect. Ultra has less options on secret screen than premiere. Perhaps this is firmware issue. Maybe is hardware issue.

Given the ultra problems, I am going to copy all of my comments, and ask a mod to delete this thread as it has gone seriously awry. There may still be a tablo problem, but there is a definite Roku problem.

Would this be proper to do, or should thread be left as it is?

1 Like

Leave the thread as is (and add, as you see fit), there’s a lot of interesting information here. The problems you’re describing are unusual and the thread has spawned some great (and interesting) insight from other members. I’m personally curious to lean if / how this eventually works out.

Ok, leaving as is. Got some more information though. I think my Roku 4660RW is pooched.

Secret System Screen, box runs between 72-80C. Occasionally, it will drop to 34 or so, but then back up over the course of 1 second. I can almost predict pattern now according to fluctuations in temp, but not over time. Yes, bar is turning yellow, has turned red a couple of times for a split second.

Secret Wireless Screen. Signal Level is usually zero. Ant1 will hover around 45-48. Ant2 will indicate 34-50. Then Ant2 goes to zero. Signal Strength goes to zero. Ant1 goes to zero. Oh, and glitch meter ramps way up, turning red, all the way across. Status messages indicate high numbers of connects and joins. Router logs (Cradlepoint MBR95) does not reflect. Also have a high rate of glitches displayed here as well, up into the millions (7 number places).

I suspect the box is running high on CPU temperature (voltage is 860mvolts though), which is causing errors executing and gathering data. The box has not been dropped or abused, just has been happily sitting on the dresser of the bedroom that is maintained at 72-74F (22-23C) temperature. Year 'round. Box orientation does not seem to have an impact on temperature or performance. I have not been able to measure output of power supply yet, can’t seem to find my Fluke anywhere. But, my Roku Premiere+ seems to work just fine on it. It also seems to work just fine on the Cradlepoint MBR95 router, and is apparently very happy with the seemingly 150+ channels the family has installed on/in it.

I have opened a support ticket, though I had to edit and revise a few times to get the core information into the original complaint. Oh, another update too. When the Ultra was unplugged (cool down, test thermometers (working btw)), the Tablo app did update channel list to 65. Should have been 72 or 77, but at least it updated. Ball is in warranty / tech support’s court now, I hope that I won’t have an interesting time dealing with them.

Factory reset any Roku giving you troubles and see if it fixes the problem.

He already did:

My Roku Ultra runs within the same temperature range as yours, but mine doesn’t have a guide issue, nor any other issue worth noting besides the Twitch app tending to force a crash and reboot of the Roku if I move around in the app too quickly.
However, the Roku Twitch app isn’t being updated any more, so I’m not surprised it’s having issues.
Still keeping it, though. :slight_smile:

Correct me, if I’m wrong, but sounds like you have the following:
1 - Tablo (you only have 1 Tablo, right?)
2 - Rokus
2 - Routers
1st Roku connects to 1st router, while the 2nd Roku connects to the 2nd router.

Which router is the Tablo connected to?

While I don’t think your network configuration should matter regarding the guide, you do have a different set up than most.
For example, I have multiple Tablos, multiple Rokus, computers, smartphones, and tablets on my network, but am only using 1 router.
Each player device can connect to each Tablo, and everything works as expected.

I have:
(2) Roku boxes, a Premiere+ and an Ultra (newer I think). Both are on Cradlepoint MBR95.
(1) Tablo 4 Tuner, connected to 1TB Seagate Backups and to Xfinity Router (MBR95)
(1) Router, Cradlepoint MBR95, connected to Linksys CM1016 modem on Xfinity
(1) AT&T Gateway connected to AT&T vDSL
Tablo is connected to Xfinity Router, as ultimate goal is to kick AT&T to the curb. Hate them.
Both Rokus are on Xfinity Router so they can use Tablo, and it does work on both Roku other than guide problems on Ultra. The ultra has started having a lot of buffering issues, probably related to failure in networking on it.

The AT&T Gateway is still functional only because there is a couple months remaining on contract that was renewed when we moved the service. Until introduction of tablo, AT&T was used by Roku Premiere+ due to invalid family recovering. She binges She also wasn’t happy when we drop-kicked DirecTV. Heh. Since the introduction of Tablo, both Rokus were moved to Xfinity router.

Other upgrades are in the works, especially using a high end router that supports open source and is equipped with eSata and USB3 ports (Linksys WRT1900ACS). But, I have put the brakes on any changes from what is listed above until a resolution is reached. Don’t want to further muddy the already murky waters.

Pst! If you’re still seeing weird, behaviour (sorry for the wait), don’t hesitate to reach out to our support team.

Shhh, we’re napping.

Napping…I wish.
Finally got return-to-work from doctor, of course is restricted. Anywho…

Have been communicating with Roku regarding pooched networking behavior, which has been confirmd, but not for reason that I thought it was. I was thinking that there may be some issues with the Roku in a BGN environment, as a Straight N works fairly well. Ran on that for a few days, then similar issues began to occur. Started some in-depth stress testing on the router, and it is failing after all. Direct connect to router works wonderfully. Wireless does not, I am seeing about a 15% packet loss from 3 feet away, and 25% packet loss from location of Roku Ultra. Signal strength of the Roku Premier+ is way down in the crapper, showing between 5-10 on scales. Power draw by the router is all over the place, dropping to 100mA (at 12v is 1.2watts) and spiking at over an amp for extended periods. This is taking place when WAN is connected, no wireless devices connected (all devices set offline), and LAN ports are disconnected. Further investigation with an oscilloscope has yielded that the finals / amplifier are ringing, meaning that I have noise out of the router and into the antennas. So, I am on the hunt for a new router.

Looking at a Linksys WRT3200ACM, mostly due to its capability of running open firmware and sits higher on the shelf so air flow underneath is greater. Yeah, I know I can prop others up higher, but there are not any vents on bottom of what I have looked at. I am also looking into taking plunge into a whole house / mesh solution as well. Definitely not google though, last thing I need is something else spying on me and reporting my usage patterns back.

In the meantime, I have the Rokus both running on the AT&T Pace 5268 Gateway, and are doing much better. For some reason, port isolation is turned on, and the Tablo Apps, incl via web browser and on my phone, are not able to see the tablo tuner. Though I can see which IP# has been assigned, I can’t ping it or trace route, where I could before on the MBR95 router. And of course, AT&T is saying to talk to Pace, who says the gateway is supported solelely by AT&T. Lather, Rinse, Repeat. AT&T is now talking about replacing the gateway. Again. 3rd time in 6 months. No way. As long as the females in the house are able to watch True Blood, Justified, and a slew of other shows they are happy and could care less what is happening. I just have to do my diagnostics when everybody is asleep or not watching TV (which is NEVER). I am really surprised that this Samsung PLASMA 65in TV hasn’t burned through the wall its mounted on. 700watts of power being used at any given time. Sorry, that is another irritation of mine.

Once everything is squared away, I found another project that I am going to look closer at. USB / NAS. The component device has terrible reviews, but I am going to take a really indepth look at using a RasPi to act as a go-between the tablo 4 tuner, and mounted folder on my 60TB NAS JBOD Raid array. Yup. When I was off work with a bad wing, I had entirely too much free time that was not effectively managed.

I’ve been using a RasPi 3 for 2 years as a media server. Using Tablo Ripper to get shows off the Tablo and onto a drive connected to the RasPi. Playback from RasPi to Roku & LG TV is via MiniDLNA. Did not want to install heavy software like Plex on Raspbian.

Very Nice! I have seen similar projects in dev and a few actually working.

My project, vaporware v.0.0.1A, will connect to Tablo USB host, then manipulate the data to goto the NAS. Once there, then I can access and pull files as needed for the blade (purpose built server I made before oil field tanked, 4x Xeon x 4 cores ea, 48GB memory, diskless) won’t run Windows tho) to work it’s magic killing ads and such. Would love to get my SGI box up and running, but way old and antiquated.