Guide Blank on Amazon Fire TV Box (SOLVED)

I’ve been running my 4 tuner Tablo since December of 2015 and while I did have a few guide update issues, like the guide only updating every 2 - 3 days, I have never had the guide be totally blank until yesterday. I watch the news in the living room before work and the guide was fine yesterday morning. When I got home last night the guide was blank on our Gen 2 AFTV box. First I tried exiting the Tablo app and going back in. Then I disconnected from the Tablo via the app and reconnected. I then manually downloaded the guide, although it said it had downloaded 15 hours ago. Then I rebooted the AFTV box but none of these things helped. I then tried from the Gen 1 AFTV box in the bedroom. The guide was blank there too so I figured the problem was upsteam with the Tablo.

So I rebooted the Tablo. The guide was still blank. Then I powered down the Tablo and the external hard drive for 5 minutes and restarted everything. The guide was still blank. While I was filling out a ticket I opened Tablo on my Android phone so I could take a screen shot and after it synced, the guide was there! So then I went to our spare bedroom and tried Tablo on our Roku 3. The guide was fine. So the problem was only with the Gen 1 and Gen 2 AFTV boxes.

At this point I uninstalled the Tablo app on the Gen 1 AFTV box and reinstalled it. Once it synchronized, the guide was fine. I did the same for the Gen 2 AFTV box and that worked as well. It seems really strange that both of these AFTV boxes would have the same problem with Tablo at the same time. My best guess is there may have been a AFTV update come down that somehow affected the guide.

I just wanted to share in case someone else runs into the same issue. Save yourself some time and just uninstall then reinstall the Tablo app on your AFTV box.