Gen 4 Roku app - no sound on broadcast channels

I have a 4th Generation Tablo DVR. It works fine when streaming to my iPhone and iPad. However, when I stream via my Roku device (Roku 3 - 4200X), I can see the guide and view the video stream, but there is no sound. This is true whether I am streaming a live broadcast or a recorded program. However, if I choose one of the Tablo Streaming channels, the sound and video are displayed just fine. I’ve looked at all of the settings on the Tablo app and my Roku, but can’t find anything that seems to affect the issue.

Has anyone else experienced this, or have a solution?

Try changing the Audio setting on the Roku (from Auto to Stereo maybe).

Yeah my almost 14 year old TV is fussy with the HDMI signals from Roku and my gen4 Tablo. Ultimately I changed all 3 settings to Auto. At first I had 2 of the setting set to stereo. Recordings played fine but I kept getting ticking/snapping sounds at the beginning of play. Changing all 3 to auto eliminated the ticking and recordings play fine.

You may have to play around with different combinations of these settings.

1 Like

Thanks for the suggestions. Unfortunately I’m going backward. I tried setting the audio on the Roku to Stereo, rather than Auto. However, now I get no video at all from Tablo – neither recorded or live from broadcast stations. It’s not the Tablo – it works on my iPhone and iPad. The suggestion about the TV made me wonder if it was my older Vizio TV that it’s connected to. I plugged in the Roku to my newer Samsung TV (unfortunately, not new enough to get the Tablo app as a Samsung Smart TV app.). It was the same experience – no video or sound on any channel except Streaming channels, and other non-Tablo apps.

So what I know is that it’s not the TV. I bought a new high speed HDMI cable to see if that would make a difference, but it doesn’t. Not sure where to go from here. I don’t want to keep spending money on devices (like a new Roku), since my preference is my Apple TV. I guess I’ll just have to wait until I get accepted for the beta program on that device, or until it is released.

One last post, in case it helps others. Apparently, there is a correlation between the audio setting and video display (bizarre, but true). If I set the Roku audio setting to Auto (DD), I get video on both my old Vizio TV (which only has stereo sound) and my Samsung TV (which is hooked up to a 5.1 audio receiver). On the Samsung with Auto DD I get both audio and video. On the Vizio, I get no sound, but video.

If I change the Roku audio setting to Stereo, I get no video on either TV. Not sure why the video should not work based on the audio setting, but it does.

This looks like a really old Roku device. I’m not sure if it’s a supported model (you can search Tablo’s support pages to discover this) but you may need a newer product. I understand that you’re only having an audio issue right now, but it’s definitely something to consider.

One thing you can check is your TV’s HDMI input setting. You may need to change this from “Auto” to one of the manual options. This can help clear up video and audio compatibility issues with older HDMI devices (ie, your Roku). However, changing this setting may interefer with other devices connected if your TV does not have manual settings for each port.

Other than checking the support pages to view recommended STBs, look around the topics here and see what others are having success with. I continue to recommend the $20 Walmart onn 4k streaming box due do it’s price and compatibility.

Good luck and I hope you are able to use your new 4th Gen Tablo very soon!

My 4200 still works great on a 2018 sony and a 2012 panasonic. My 4200 is set to auto which is DD+ and DTS. But you spoke the brand that seems to show up most often in the forum - Vizio.