Gen 4 LED mystery

One day last week I noticed that the blue LED on my gen 4, which normally can be seen from across the room, was not visible. Except for the LED being off, the Tablo was working normally. I made the mistake of deciding to troubleshoot this, and first rebooted my router. Tablo now would play recordings, but no longer receive live TV. I rebooted Tablo using the reboot button, with the same result. I decided I would come back the next day to see if the problems had self-corrected, and indeed the next day everything was working normally again, except still no LED.

To be precise, when I rebooted Tablo I could in fact see the LED go through its blink and flash sequence, but I had to turn off the room lights and peer in to see the the LED, which was extremely faint and almost invisible. As I said above, normally the LED is easy to see from across the room. BTW I checked several times and the LED setting was “on” in all of my apps, IOS and Roku, throughout all of this.

I forgot about all of this until today when I happened to look over at the unit (it’s in an infrequently used room) and there was the LED blue and bright as ever. I had made no changes or adjustments in the interim. I also looked through some recent forum posts and back when I did my troubleshooting was also the day/evening when posters were talking about a server outage. Coincidence? But nobody mentioned their LED going off, that I could find.


Isn’t there an option to turn the LED off? Maybe that somehow got enabled, or some bug happened.


This morning, the LED is once again not visible.
Tablo is functioning normally; the LED setting is “on” in all apps.
I have made no changes (reset, Tablo reboot, router reboot, etc) since last noticing that the LED had lit up again a few days ago.
So I guess this Tablo has been switching the LED on and off of it’s own accord for some time, and I only recently noticed.

Sounds like a defect with the LED circuit which may get an in-warranty repair or replacement.

1 Like

I’ll wait on doing a warranty claim, since the LED is not mission critical and the unit is working properly for OTA/DVR, though more firmware updates would be appreciated. I have 10 months left on the warranty in case there are more malfunctions.

It’s been many years since I needed to make use of the warranty on an electronic device, due to manufacturing defects. I’m a Tablo newcomer. What is the experience of others on the forum regarding Tablo warranty fulfillment (turnaround time)? Are manufacturing defects more common on Tablos than on other electronics you have owned?

This is my first Tablo product so can’t render an opinion at this point. Industry standard used to assume that there will be a 1 to 2 percent defect of units that get to the customer. I’m guessing that there is a poor connection on the LED where it was fine when it left the factory and disconnected over time. It happens.

Two 4th gen units that I have purchased have been working well in every way since they were purchased in late October. (This is the hardware…software is a whole other discussion.) I

1 Like