Firestick SLOW to access tablo

When bringing up the tablo app on my firestick, it is painfully slow to load. The tablo is working fine because it is recording content without lag or gaps.

I also have Roku connected devices without any problems at all, it’s just the one fire stick. I’ve done resets, cleared the cache memory and it still takes about 3-4 minutes of spinning before the menu appears. Any suggestions?

I don’t have a Firestick, but it would be helpful to know the exact model. I know some Firesticks had issues.

The older non-4K versions of the Firestick are noticeably slower than the 4K models (which have faster processors).

Not sure of exact model, but it is fairly new (1-2yrs) is 4k and voice control.

It has worked fine up until last few weeks. Like I said in original post, all other rokus and firesticks in the house are working fine and is only acting up on the most used (living room) tv. For now, I will swap it out with another one.

I was reaching out to see if anyone had this issue because the wife is no longer convinced the tablo was a good idea and avoids using it because of the issue and I have apps on the firestick that I can not get on Roku. Thanks again for any ideas.

I have 2 older (3 years old I think) Firesticks as well as a new 4K model. We use one of the older ones for a TV we take out on the deck. It’s pretty far away from the router. It performs just fine. The other old one is on a TV in a bedroom on the opposite end of the house from the router. It also performs just fine. They don’t show any big noticeable performance drop from the 4K model when it comes to Tablo. Did you try uninstalling the Tablo app then reinstalling it on the suspect Firestick?

I know you’ve already done a cache clearing and reset, but try uninstalling and then reinstalling the app on the problematic firestick… sometimes this can rectify a number of problems. edit… beat to the punch by SophieCat

I have not tried the reinstall. I will do that and let all know if it works out. Thanks again.

Very odd that it just started acting slow, a 4k stick should work just fine compared to the slower models. Good luck with the wife; been there, done that.

Worse case if reinstalling the Tablo app does work, you can try factory resetting the stick. Hope it doesn’t come to that.

I have a few year old Firestick 4k and know your pain. I also have a Roku Ultra - the version right before the new one that added DV support. The Roku is warp speed to access my Tablo and the Firestick is impulse power. I tried reinstalling the Tablo app on the Firestick and have concluded it is just an app issue since the Roku app accessing the same Tablo is a far superior experience.

Neil

I tried the app delete and reinstall, and the same issue occurs. Roku works just fine. I have since swapped firestick out with a Roku from another (less used) tv and the Roku does the job with zero issues.