Error - Repairing hard drive


For the last couple of days, I have been getting ‘Repairing hard drive’ error. Here is what I have done so far. Note that I have been using my current setup close to a year without any issues.

  1. Initially I noticed that wasn’t able to view any live tv or recorded programs. Hence thought of rebooting the device. This is when it started giving me that error.
  2. I have rebooted it several times and the blue light was blinking 1/sec and left for 16 hours without any progress.
  3. I unplugged everything and re-plugged still the same issue.
  4. Note that at this point, I haven’t done a factory reset. Only rebooted it a few times.
  5. I removed the old WD 1TB and plugged in another spare WD 500GB drive. This time it formatted the new drive and was able to record and view live tv programs.
  6. I did open an ticket. Ticket number: 13990
  7. I now have connected both the drives to Tablo and if I try watching a program from the 1TB drive, it says, ‘Player error, file not found on disk’. Now the blue light is not blinking as it has one usable hard disk I presume (the 500GB one).

a. Do I have a WD 1TB gone bad? How can I confirm that it has gone bad?
b. What can I do to fix it?
c. If I can’t fix it at the very least I’d like to get my recorded programs. I have about 540GB of recorded programs. Note that I tried ‘Tablo Exporter’ on Mac and it does not read the 1TB hard drive but does the other 500GB one.
d. How can I avoid this in the future? Should I get an SSD? Better longevity without the moving parts?

Any help or suggestions is much appreciated.

Thank you!

This sounds like an issue for Tablo Support directly - open a support ticket with them. You’ll have to wait until Monday.

The Tablo might have 2 USB ports, but it does not support using 2 drives simultaneously. You can only use 1 USB port and 1 USB HDD at a time.

Thank you, @theuser86, I have already opened the ticket.

I didn’t know that I could not plugin two usb drives. I guess only my 500GB drive is working then.

By the way, @theuser86 is there a way to connect the usb drive to the computer and get the programs off that way instead of using Tablo Ripper or Tablo Exporter?

Somehow my 1TB WD portable drive got corrupted and lost .6GB worth of recordings :frowning: