Dual HDMI Becomes Sluggish if Not Reset for a While

Morning folks:

I’ve been using a Dual HDMI for a few months now and, in general, am very pleased with the unit. However, I’ve seen at least two instances where the user interface became sluggish and the video started stuttering intermittently. In both cases, a reset solved the problem. While it is nice that there is an “easy” solution, as a firmware engineer I can tell you that such symptoms usually indicate “memory leaks” (firmware defects).

In addition to the above symptoms, when the system was in its sluggish state and I was playing a video, hard drive accesses were very frequent. However, after the system was reset and was operating normally, hard drive access were much less frequent when watching the exact same show. This further supports the theory that not all allocated memory is being freed when no longer needed (likely resulting in much less memory available for use as buffers for playing video, ultimately resulting in sluggish operation).

Given the above, it sounds like you folks have some memory leak related defects in the design and/or implementation of the firmware that should be hunted-down.

-Michael

1 Like

Yup, that’s why everyone is complaining about it everyday.

What about the app/device you’re using to access the tablo? Frequently a single user reports a bug which they’re the only one finding it. It’s super how you’ve already found the solution.

I’m using the Dual HDMI version of the Tablo. Right now I only use it connected directly to my Sony Bravia via HDMI. No “app”.

While I believe I understand what’s going on, locating and correcting “memory leaks” is a very challenging business. Unfortunately, it’s probably one of the most common defects with software and firmware that dynamically allocates memory, but a reset will always fix it (at least temporarily). That’s why “reset” is always at the top of the trouble-shooting flowchart! ;^)

-Michael

Unfortunately technology doesn’t always work the way it’s suppose to, not all the time for everyone - of course been there done that.

Just saying, if it was a flaw/bug, it would be widely known. If your hypothesizes is correct, a possible hardware defect?

yea… temporarily isn’t actually “fixed” :neutral_face: Just helps us feel better even if for a short time. :wink:

  • good luck

A “memory leak” is an obscure software/firmware bug (defect) in which one part of the code allocates a certain amount of memory for a temporary need but, because of a flaw in the code, doesn’t always de-allocate (free) that memory for later use by other parts of the code. Over time the amount of memory available for allocation gets smaller and smaller until the system eventually starts “choking” for a lack of “free” memory (when the system becomes sluggish and video stutters)…

I have the Quad HDMI and it is fine, don’t think I restarted it once yet. I do have it hardwired with ethernet.

Has Tablo confirmed any of this or are we just guessing and spreading rumors as mine works fine. I am only asking as you know someone is going to see this, even if not really memory leaks and go to Reddit or something and then it spreads even more that Tablos have memory leaks when they might even not.

I’d say more of a “hypothesis” than “guessing”, as I’m an engineer whose been developing firmware for safety critical embedded systems for a few decades. ;^)

I’m also connected via Ethernet.

If there was an officially confirmed issues it would be announced. It’s not uncommon for a single user with troubles posting “there’s a bug” while no one else encounters problems. There are numerous post from users touting themselves as a Grand Poohbah and has the answer to what is wrong even.

You’re likely correct, it adds to the “I read somewhere…” or “I heard…” or “Someone said…” with little substantiation.