Delving deeper into the Roku "Loading..Please Wait" issue

After bragging how well my system was performing this morning I noticed an inordinate amount of “Loading…Please Wait” messages during playback of a recording that I had started earlier in the morning. Upon investigating I found a scheduled recording had started around the same time, so I am thinking there may be a connection. I was using a hard-wired Roku 4 at the time.

My hard drive connected to the Tablo is a 5TB Seagate Desktop Drive model SRD0NF2.

It seems some consider that the “Loading…Please Wait” message describes a “Buffering” condition. I my case I suspect it is a program segment misread, possibly caused while the hard drive was doing double-duty both reading and writing to the disk at the same time. Some times the result of the “Loading…Please wait” action was to repeat the same program segment two or three times before continuing. This does not describe to me the concept of “buffering” in the classical sense.

if the system was indeed “buffering” one would think there would be enough read-ahead program segments in the media player cache to allow for temporary disk re-reads or interruptions. Maybe other media players "buffer but the Roku app does not “buffer” at all, or perhaps has too small a buffer cache?

Realistically, does it not seem very possible that simultaneous reads and writes to a hard drive via a USB 2.0 port could on occasion result in the “Loading…Please Wait” message that some users are experiencing?

Hopefully if the only real problem with the Roku “Loading…Please wait” condition is a too-small read-ahead buffer cache, perhaps that could be corrected in software.

It would be interesting to hear from other users who may have experienced random performance issues during program playback to see if perhaps a program was being recorded at the same time.

This may be semi-related but in the 4-6 weeks I’ve had my Tablo, I have had 2 instances where the playback got stuck in a “Loading please wait” state, where it plays the same video segment for about 5-10 seconds over and over. The first time it happened, it was exactly the time another show started recording. The second time was during a commercial while watching NBC Sunday Night Football, and when I exited out, went back in, it continued. I eventually flushed tuners, and tried to re-tune to the channel, I got “Error weak signal” which was discussed in a different thread. It was very strange because I was watching the pre-game on NBC for over an hour without a problem and as soon as the live football action started, I got that error and the playback loop. I watched something else, tried again an hour later and it was fine for the rest of the game.

I seem to be seeing a possible correlation with poor signal quality and “loading please wait”. I’m not seeing any completely lost video, the video backs up and plays without missing anything so the signal is not so poor that video decoding is lost. My speculation is that maybe error handling / error correction is creating additional processor loading that is causing buffers to not be serviced on time.

In my case the signal quality issue may be excess signal rather than a weak signal. Difficult to say since the only insight we have into signal quality is gross signal power as indicated by Tablos bars/dots. Unfortunately, it is entirely possible to have a strong yet corrupted signal (multipath, excess amplitude, etc) so this is not a good indication of signal quality.

And yes, this is a problem with Live TV as well. In fact, I haven’t actually even recorded anything as of yet.

I had this exact problem with bad reception during a Browns game. It was also with public roku app and the pre-2.2.6 release. The wind was blowing (as was the Browns performance, of course) - leaves were messing with the signal. Picture pixelation on the web viewer at the same points as the roku ‘repeat loop’.

Doesn’t the Roku API have a section about it’s HLS player and some conditions that cause the “Loading…Please wait” message?

This is more or less exactly what I experienced Sunday night (and was during the football broadcast), even down to a super brief ‘weak signal’ item (hadn’t even mentioned before, because it was so breif and didn’t come back). I also had been watching the game about an hour, and watched really a full day of football on Fox/CBS with no other issues. This was on 5ghz wifi Roku 2 and 3 running 6.2.

To the OP’s theory, I was dual recording Quantico while watching the game (and recording the game). Haven’t experienced it since I went wired for testing, but some things I did during the game while issues persisted:

  • Immediately stopped the Quantico recording, rebooted Tablo
  • Downgraded recording quality from 5 to 3 mbps (rebooted Tablo)
  • I started watching on my laptop (chrome browser), which worked well. After the game ended, maybe 2-3 minutes after, the play just hit a dead stop though. Admittedly, I was tired at that point and didn’t look at it further…could have been alot of things, including my browser.

Put on other threads, but in the last few days I’ve been testing on a wired setup on my Roku 3…no similar issues to speak of on 5mbps wired.

Don’t you just love Murphy’s Law?

While I was watching another program recorded from the same Television channel I mentioned earlier in this thread the “Loading…Please wait” message appeared with regularity. At that time no other channels were being recorded.

The video signal quality at both times was excellent, so I am going to follow Dan_Cooper’s lead and try recording with an attenuator in the antenna line at the Tablo itself. I have several passive coax splitter units left over from the days before I installed amplified distribution devices in their place. I will start with a three-unit model with -3 / -7/ -7 db settings. I will start with the -3db setting and with 75-ohm attenuator plugs in the unused connections to assure that the splitter is loaded down and does reduce the signal to the Tablo. I’ll check real-time views of the TV channels to be certain I didn’t hose anything.

Now to wait to see the results. Gee, this is almost as much fun as a Snipe hunt.


I plan on doing exactly what you’re planning on when I get home. I went out at lunch looking for a 6 or 10 db attenuator but no luck. I’ve got some inbound in the mail but I’d like to make some progress this evening.

If only we had some diagnostics with some more detail on signal quality, received errors, etc. etc. :wink:

keep me updated on this i would just like to see if this works

Ah, it must be Poltergeist. I watched about half of a program on my hard-wired Roku 4 during which “Loading…Please wait” happened dozens of times, and each time the program segment replayed two or three times before continuing.

Then I had a Eureka flash (or a Senior Moment) and closed the Roku Tablo app and opened the one on my IPhone, and continued to watch the rest of the program with no runs, hits, or errors whatsoever!

So now I guess I’ll have to eat crow and discount most of my earlier presumptions. Since the recording played OK on my wireless IPhone, how could I realistically condemn the recording itself? How could I now realistically blame simultaneous recording and signal strength as causing the problem since the recorded file(s) itself now seems to be OK?

I guess I’ll just have to consider it a problem with the Roku Tablo app itself that exhibits itself randomly depending upon the channel recorded and the broadcast content and the recording setting and the phase of the moon and the price of tea in China and the number of Angels dancing on the head of a pin and number of sunspots and …

OK, pay attention to this, Roku sports fans!

I replayed a recording that exhibited multiple “Loading…Please Wait” messages using a wired Roku 4, and simultaneously watched the same program on my wireless IPhone.

I observed the program on the IPhone continue seamlessly thru program segments while the Roku playback continued to display several LPW events.

IMHO this should rule out any particular flaws in the recording and certainly points the crooked finger of fate at the Roku Tablo app.

In case it gives a clue, the problem recording was from a PBS B&W rebroadcast of events around the 1938 broadcast of War of the Worlds on radio.

Care to comment, folks at Tablo?

Here’s hoping someone with capability will repeat my test as a sanity check.

Not to appear overly critical, a movie that followed the recording I just described on the same TV channel plays back flawlessly using the Roku 4 player. Go figure.

I’m super interested in all of the testing/findings you’ve done, so thanks for that and sharing. And full disclosure, I’m a UNC grad :smile:

I’m probably out of my league here, so by all means anyone correct me if so, but thought I remembered reading that remote viewing (so through an iOS or android client) uses one of the tuners to transcode the viewing stream to the bitrate you set for upload speed. If that’s correct, it’s possible that the Tablo’s transcoding is correcting on the iPhone for whatever buffering the Roku isn’t?

Interesting point, Matt. Worthy of a response from Tablo tech support.

I also just tried to watch the problem recording using a wireless Roku stick, and the performance was (in my opinion) 10 times worse than the Wired Roku 4 performance. Very long LPW events and some freeze-ups until a button pushed on the remote. I could see how a user who only owned a Roku stick could end up being frustrated to the max when trying to view some recordings exhibiting many LPW events.

BTW, I have a brother who is a UNC grad. No favoritism in our family. :grinning:

I should have added earlier my IPhone was using my local LAN wireless broadcast at 2.4 GHZ as opposed to the Sprint network only. That might have had an effect as to whether or not a tuner was being used.

I switched over to Sprint-only LTE connection and saw poor performance trying to play one of my recordings made at max resolution but I cannot fault Tablo for that since I only have a slow 6mbs DSL service.

@Wolfpack - Definitely appreciate your troubleshooting and the team is following your posts. We’re working to try to find the specific root of this problem but it seems to be in the communication between the Roku and the Tablo.

@TabloTV I know you had previously mentioned that there were some issues with the bonjour stack you guys were currently using … could this be related? …

@ericgus - I am but a lowly marketer so I don’t like to make guesses about code. I know the server team & the Roku team are working together to identify the issue but I don’t have any further updates.

@TabloTV sure understood … I only mention it because on my iOS/Macs it seems to work fine and the bonjour stack on those devices is from apple which created it.

@ericgus - Interesting guess but could it also be that iPhones and iPads and MACs have waaaaay more processing power than a Roku…

Except my Roku 4 wired should have been able to play my “test” recording as well as my IPhone.

I’m out to pick up an Amazon Fire stick to install right next to my Roku stick on the same SONY A/V receiver and see how it plays my “test” recording.

Stay tuned. Care to place any bets in the interim?