Crashing increasing over past couple of months

When reaching the end of a recorded episode the last few minutes are usually commercials. We fast forward to the end and press play so the episode will be marked watched. We’ve tried leaving more time at the end of the episode (10-20 seconds) and sometimes this helps but what’s happening is (with increasing frequency) instead of returning to the recordings menu, the app apparently crashes and we’re returned to the Roku home screen.

Anyone else experiencing this or have suggestions for avoiding this?
Quad Legacy unit


We use the “mark watched” option.

Thanks mbellaire, I think we’ve tried this too. When we hit the ‘back’ button ( left arrow at top) of the Roku remote it will sometimes crash the app as well. Unfortunately it doesn’t do it every time. But the longer we watch, binge, the more it seems to crash when exiting the recording.

Our Roku used to lock to a Black screen when exiting after viewing a Tablo recording. However, that was fixed a while ago. When that was happening to us, we would just hit the home button on the Roku controller, and then go back into the Tablo app. A little annoying but it worked.

What Roku do you have? The newest Ultra seems to give some folks problems.

Started as soon as roku OS 13 was installed. It’s a pain in the ass if you have multiple units since the app starts up in the unit used when it crashed. And that unit may not be the one you want. I think roku has installed some changes that seem to lessen the problem. So I would manually check for updates.

It’s an older Roku Ultra. Probably 3 yrs or so. Yes, a little annoying.

It seems to happen more frequently if at the point you are done watching you use the return button rather then pause and then return.

Thanks zippy,

Not sure I follow the multiple units scenario though. We have a stick on wifi and an Ultra hard wired. I’ll check both for updates although I think they’re set to update automatically.

Yeah, It’s just pretty random. Both stick and Ultra OS 13 build 24056. No updates available att.

Hopefully, Tablo is on it.

(redacted) Did not see
in the OP.

Thank you, zippy.

This is the legacy app. And it didn’t happen on roku OS 11 or 12. Of course the roku OS 12 video player didn’t work well with legacy tablo until 12.5.5.

This doesn’t really work very well for multi-unit users. If you have multiple units the app will display the list of units at app start if the app is left in disconnect mode.

With this problem you may want to cancel playback and delete the episode so you can switch units. But you don’t get the chance to delete the episode since the app blows back to the roku menu. You then have to start the app just to delete the episode and then switch to the desired tablo unit.