Commercial skip slowing or stopping internet connection

For some people there is an issue with commercial skip slowing or stopping their internet connection. I hope Tablo decides to put a bandwidth limiter option in the Tablo settings but many routers can accomplish this task on their own. I wanted to start a thread to explain how you might fix the issue on your own.

The problem: Commercial skip must upload large files to the server to process commercial skip. The files are around 100-200mb per hour. Your internet upload speed is different from your download speed with most providers. Often times upload speeds can be less then half of your upload speeds. For instance my ISP offers plans with as little a 1Mb/s upload speed for an 8Mb/s download speed. The slowdown will depend on how many shows you record, how long they are, the quality you set for recordings, and the upload speed.

Solution 1: Turn off commercial skip(but who wants to do that?)
Solution 2: Reduce recording quality and disable Dolby surround(yuck!)
Solution 3: Enable Quality of Service on your router!

QoS or Quality of Service is meant to ensure important services and devices get the internet bandwidth they need. For instance phone service, or video streaming. This option could be hidden in a lot of different places. I’m going to start with the Asus routers because I really like their router and that is what I use. Feel free to ask about other routers and I’ll try to help.

Before you go any further you will need to determine your internet speed. You can check with your internet service provider or you can do a real time speed test. Keep this number handy for later!


  • In a web browser go to alternately will usually work. If neither of those work try,, or

  • Log in with your user name and password. If you haven’t changed those use the administration password admin and user name admin. If they are still the default passwords I urge you to change them now!

  • Click “traffic Manger” on the left column.

  • You should now be in the QoS tab.

  • If it isn’t already set to ON then turn it on by clicking the OFF button. It will change to a green ON button.

  • In QoS Type select Bandwidth Limiter

  • Click the pull down menu Please select the client name

  • Select Nuvyyo Inc. That is you Tablo.

  • You probably don’t need to worry about Tablo using too much Download Bandwidth so feel free to put a large number in there. It can’t be left blank however and make sure you give the Tablo plenty of bandwidth for downloading guide data / cover art images.

  • You will have to decide for yourself what amount of bandwidth you want to allow your Tablo to have. Put that number in the Upload Bandwidth box. Nuvyyo recommends an internet connection of at least 1Mb/s upload. For some people that isn’t possible and you may opt for a lower speed.

  • Once you have entered the Upload speed click the + button.

  • Click the Apply button and you are done! It may take a few moments for the setting to be saved.

For those with limited upload speeds below 1Mb/s you may need to spend a little more time finding the correct speed setting for you. It may involve testing various speeds settings. You could decrease quality settings for recording TV shows in addition to limiting the Tablos upload speeds. Lower upload speeds will result in your recordings taking more time to be processed.

1 Like

Something to note - It is indeed best to put a higher number for download bandwidth as to not limit the speed of download of guide data or cover art images.

Sadly I can’t reference the source, before this was public, it was noted it was the “playlist” and/or the snap_grid or the preview thumbnails.

This suggest more of the actual recorded program is actually transferred?

I updated that section. Good call!

1 Like

I wish I knew of this topic a couple months ago. I have been battling with my internet provider, CenturyLink, for service stopping on a regular basis. My DSL service is 40m down and 2 m up. While streaming Netflix, or whatever, crashes would occur at ten minutes after the hour or half hour (8:10pm, 9:10pm…) which I now realize are at the conclusion of recordings. CenturyLink escalated a service tech visit, and naturally a failure did not occur, but proved issues were not from outside the house, so I was billed $85 for the visit.

I turned off commercial skip for now, but will tweek QoS later. Given that my issues are 10 minutes after the recording completes should I assume the download speed is the major issue?

My other Tablo is connected to a more robust ISP and works fine, so I did not think of this being a problem troubleshooting this issue.

Hard to believe that this is not a problem for lots of subscribers. Might I suggest this be addressed in the weekly Tablo Tips and Tricks email?


Since August, I’d been having a large number of my recordings marked with failure to process commercial skip notes, sometimes noting a recording problem. Many of these recordings had some break up in content. I have a large attic antenna that’s provided fantastic performance for 20 years, and it continues to provide service with no breakups to the TVs in the house through a distribution amplifier, so this seemed suspicious. I eventually realized that the problem recordings seemed to have all of their breakups 8-10 minutes into the episode- about the point where previously recorded shows would have finished thumbnailing and would upload to the Tablo servers for commercial-skip processing. As a test, I disabled commercial skip- all of my recording breakups have stopped. I suspect the Tablo box is sometimes becoming non-responsive during commercial skip content upload to the point of affecting ongoing recordings. (I have 200M down/10M up internet, so I don’t believe my connection is unreasonable.) This is another disappointing aspect of the current commercial skip implementation on top of the 10-20% incorrect marking of commercials and recordings that failed to get commercial skip processing due to processing-server overload. For now, I guess I’ll leave commercial skip turned off, enjoy my clean recordings and otherwise fantastic Tablo product, and hope that the feature gets improved in the future.

It’s probably the upload speed.

Didn’t read all the posts, so if someone already posted the same, my apologizes.

Upload saturation which causes ack (and other) packets to not get out the door which can cause well your internet to stop working. Bit of a case of buffer bloat. Solution is to rate limit your upload speed to just below your ISP’s max speed so that the buffer doesn’t fill and traffic from other clients (devices) will make it out the door in a reasonable time. i.e. Not waiting in line in a big buffer. Inbound rate limiting doesn’t help as much as you can’t control anything past your ISP.

Check your buffer bloat

It’s not just for DSL, I have DSL and Cable and both suffer to varying degrees. Ohh and the best traffic shaper I’ve found so far is Cake, it’s just amazing how well it keeps everything rolling. FQ Cobel is pretty good as well.

Well, I also have CenturyLink DSL with a speed of 6.144/0.896 Mbps with a ZyXEL PK5001Z modem and most, 90+%, of my recording do get CS. About 20% of the CS’s are incorrect and about 20% fail to CS, but the others are right on. Sometimes it takes over nite to get them. All tho some CS in 1-2 hrs. I do not have the expertise to know why nor do I know how to set QoS. It really works good for us because we don’t watch most of them until the next nite.

I have Commercial Skip off as I explore QoS on the CenturyLink Zyxel C3000z modem. Unlike the example above, I can’t select by client name. It also seems to be asking for IP and Port numbers for the server. I can figure out IP and Ports for my Tablo, but will need help for the server.


I have the same menu on my PK5001Z, but I do not know how to fill it out and I am not sure it would do me any good - since I am pretty happy with what I get now. Actually, at my SLooooow speed I am surprised I get such good results!

QOS is usually used to prioritizes traffic that is important and that you want to give high priority too. Think of it like a police car can turn it’s lights on and everything else let’s it get by. I can see VOIP(phone service) has been given priority on your network.

You want to do the opposite to your Tablo. That would be the simplest option. There may be a setting to throttle or limit a device somewhere in that QOS menu. That’s what you need to find first.

If your router doesn’t have that option the next best option is to give priority to the other devices in your home. If watching Netflix is your only concern give priority to the device or devices you watch Netflix on. I would assign those devices “medium” priority so VOIP remains at the top of the list.

It appears that in step 6 you can put the IP in of the device and leave everything else blank. You probably only need to prioritize the upstream traffic in this case because your downstream speed should be high enough that it won’t matter. You could however do a second filter for downstream as well just to be safe. Leave step 7 blank since the destination server could change.

In step 4 make sure to use a name that explains what the filter is doing.

EDIT: I was assuming your router would use the default netmask if you left it blank but if in step 6 the router insists on a netmask then use or you could put that in there just to be safe.

Ok, I have finally created a QoS rule that my CenturyLink Zyxel modem will accept. I am a fairly smart technical guy but CenturyLink does not make it easy and they don’t publish a manual. My old LinkSys AP is much more user friendly. I have also removed the VoIP rules, as I do not have any VoIP products, those rules were on by default.

The modem wants me to select a DSCP Classification (see picture). I googled DSCP and read the Wikipedia article. See pic on recommendations.

Thoughts or suggestions?
Should I buy a different modem?

Merry Christmas and Happy Holidays.


What devices are you applying this filter to?

I am applying this filter to my Tablo.

I don’t see the option I would like to recommend CS1. I would change the priority of the Tablo filter to low and experiment with DSCP settings.