Closed captioning on roku

Roku: 3820X - Streaming Stick 4K
Tablo: firmware 2.2.42

Hello, owner of an original 4 tuner wifi tablo, and started using it again after ~2 year hiatus, and it’s working great.
Wondering about closed captioning settings.
Each time I start my tablo app on Roku, and load up a show, the captions always turn on and I have to turn them off. Option says “always on” before I switch it off, but the next time in use they’re back on again.
I don’t see any option in settings that would control this in Tablo, and the captions in Roku settings are off. How do I set captions to be off by default?

That is really strange behavior. I was just testing my Roku streaming stick (a little older than yours), and the Closed Captioning is a global setting. If you turn it on in one app or in the general Roku settings, it will be on for all apps, and vice versa. So once I turn it off, it stays off, unless someone else turns it back on for the Tablo or another app.

If you go to the Tablo app, turn off closed captioning, verify that it is off, exit the app, and then go back into the app, are closed captions off or back on?

Is closed captioning behaving the same way for other Roku apps: Netflix, Sling, …?
If it is, then it’s probably a Roku issue.

Yeah, not sure. I’m thinking it may have been a cache issue? I reinstalled tablo and the issue has stopped.

Okay, mystery solved. Turns out it doesn’t matter which app in Roku you turn on cc, all apps are affected by this, e.g., wife was in Amazon Prime Video and turned on cc, now they’re back on when I start Tablo.
Seems like a bad design on someone’s part.

1 Like