Chromecast Issues

Hi all,

I have had my tablo 4-tuner for a couple weeks now and have been having chromecast issues. I have read other posts about it and just wanted to see if i could get an answer for my specific issues. I have changed the setting to the 720 chomecast recordings and it is all working fine when I watch it on my tablet (nexus 7 or Ipad) or my laptop. It will be playing fine but when I try and cast it the show plays for 30 sec then buffers and I will leave it for a min or longer with no change on both nexus and laptop. I disconnect the cast and it starts playing fine again. Anyone know why this would be the case?

Also for the last couple days the tablo has been overriding itself on my chromecast. I will watch something live tablo then later in the day i will use it to watchespn and it will play for about 5 mins then the screen would go blank and the tablo screen will come up and try to cast the show I was watching yesterday. Even happened to a show I deleted.

Thanks for the help and Other than casting i have loved the tablo.

Two other things that could help. The tablo is hardwired into my router, which was just provided by my internet company (centurylink/ 20mbps).

Also never have issues with chromecast with casting my screen, watchespn, netflix, hbogo etc. I use it a lot and just has the buffering issues with casting tablo.

That is likely cause the bitrate on the Tablo is higher than your wireless can support.

Any way to improve the bitrate? or should I start recording things in like 480 the lowest bit rate?

What is make and model of your router?

You could invest in a better router.



Netflix runs 1080p flawlessly to Chromecast… why does Tablo have so much trouble? I hate dumbing down the quality. My Roku handles 1080 just fine. There is a noticeable loss of picture quality when dropped to 720p (on my tvs, anyway). It would at least be nice to be able to select a lower rate when streaming to a device that can’t handle a higher rate.

I was also just wondering why I can be playing live sporting event from an app (Fox sports one, watchespn, pac-12 network) and can just cast my screen (only watchespn is “optimized” for chromecast) and it works perfectly fine no issues. But I try to play a saved (recorded) show and it is just so bad… just sits and buffers. Can someone explain?

I have similar issue if I cast from my android app. If I use the Plex Tablo channel to cast, I do not seem to get the buffering.

Guess I wasn’t the only one noticing this - my network is FAST, it’s not any issue with the network. I can handle huge file transfers and other video But Chromecast was buffering - a lot. But to me the worst of it was that it went into buffering and never stopped, you could come back 3 minutes later and it was STILL buffering. It wasn’t just a few seconds or now and then for a brief shot - it buffered and never recovered until I took other actions like stopping and restarting the stream to Chromecast.

@dougc405 @casqueia Netflix doesn’t actually give you a set quality, resolution or bitrate they’re sending. They can be adaptive since they’ve got the content saved at multiple bitrates, and they can switch mid-stream if your network has trouble processing as segment. 

Other streaming services use this benefit from this method, too. The difference is that Tablo has to transcode live - since the content itself is live. The two services are fairly difference in that respect.
Also worth noting: the Roku’s max bitrate is 3.5Mbps.

@tablosupport My question to you is why is it such a major problem with recorded stuff. Why does it have to trans-code live content that has been recorded. I have minor issues with live TV but nothing compared to when I watch a recorded show. 

Sunday for example I watched both NFL playoff games with very little issue from my tablet (nexus 7) to my chromecast. That night my wife and I sit down to watch a recorded Jimmy Fallon episode (recored at the chromecast/roku setting) and it plays for 3 mins buffers, I skip it ahead 30 sec starts playing for 2-3 mins buffering again. My wife finely gives up we go watch something else. 

If it is a recording then why does it have to be done live? Also why does it not load up the recording so buffering doesn have to happen?


The recording doesn’t have to be done live for a recording. It’s done at the time of the recording - but it can only be recorded in one set recording quality. 

Most folks have the opposite problem - the buffer on live TV is so small (whereas a recording is entirely transcoded and waiting for you to hit play) that it can be harder for the network to keep up with the stream.

We’ve seen faulty (or just plain incompatible) drives buffer the stream if they’re disconnecting/reconnecting to the Tablo too frequently, though - maybe there’s a clue there. I can take a look at your Tablo’s logs to see if there’s any evidence of this. Feel free to PM me your MAC.

I know that Netflix uses adaptive streaming, but it is easy to see when it happens . I’ve only seen it when first starting a stream. Seldom if ever once it gets going. Easier if the content is already stored at different resolutions. I guess would take too much horsepower to transcode on the fly, so that the resolution could be set at playback instead of at record time…

I was also just wondering why I can be playing live sporting event from an app (Fox sports one, watchespn, pac-12 network) and can just cast my screen (only watchespn is "optimized" for chromecast) and it works perfectly fine no issues. But I try to play a saved (recorded) show and it is just so bad... just sits and buffers. Can someone explain?

I found something out today. Was playing an old Daniel Boone show my wife had recorded. The station is a dash-3 station and broadcasts at what Tablo lists as 480i 

We played to Chromecast using my notebook and it got to a spot in the playback that it sat and buffered - and it sat - and it sat - and it sat, buffering. I tried to get it to go past that spot, I clicked the back/20 button - it went back 20 seconds hit that EXACT SAME SPOT and buffered again, I tried FF/30, nothing, it just sat and buffered No matter what when it hit the EXACT time in minutes and second of play it went into forever buffering. I dragged the slider ahead a few seconds and waited it out and it resumed play, only to do it again later at at different time spot. When it does this it ALWAYS does so at the same time spot if you back it up or move the slider, when it hits that spot it hangs and buffers 
It did this WORSE with my notebook and Chrome streaming to the chromecast but I wonder - is it when it’s grabbing the next segment of the show you have recorded? I was just told Tablo records to many segments, not a single file for a single show, but many files for a single show. Is it hitting the spot for the next section of the show and hanging up? If so, why only in windows and chrome?