Chrome Cannot Open

About a couple of months ago my Chrome lost its ability to open and shows the message that I need to change https → http, however the ‘s’ is added automatically and I have no way to fix it. Other browsers (Edge) work fine. I guess some settings of Chrome must be modified, please advise if you know which, thanks.

You can take the “s” off and it loads just fine.

1 Like

Have you tried typing in the full URL yourself?

without just and letting Chrome load it however it wants? Most browsers like to default to the “secure” site unless told otherwise.

Once you get the proper page opened, save it as a bookmark somewhere, maybe even in your toolbar. You’ll get to the right place every time with just a single click.

Of course I tried to remove ‘s’, however Chrome restores it automatically. Other browsers (Edge and Firefox) open without a problem, only Chrome enforces https. Probably this is some Chrome’s safety feature activated as a side effect after an update.

Hello. May I ask what device do you have? I have a white 4th gen, and cannot figure out how to use it in a browser or even in the windows app. They said that the white 4th gen does not support this? So I am wondering what device do you have that you were able to make it to work with edge and firefox.

Mine is an obsolete black “Lite” version. It was the cheapest option on sale. Nevertheless I am quite happy with how it works. Concerning your issue, I would start with connecting it to Ethernet (cable) and see if you can ping it. If the thing is dead you should better replace it. In general I like their design, I am an electrical engineer myself.