Chrome 123+ can't connect

I have a 4 channel OG Tablo, and it has worked well for many years now. I usually use it with a Roku, but have used it in the recent past on my desktop with a Chrome browser (Win 10 and Linux). I’ve noticed with the latest versions of Chrome (123 & 124) that I get the “spinning wheel of death” and “Connecting” after selecting which Tablo I want and logging in.

After setting the security flags in Chrome, it worked fine in the early versions of 123, but is now DOA. Is the browser version now dead, or do I need to change more flag settings?

I am having trouble today getting Chrome to load my classic Tablo at all, it worked normal yesterday, today it won’t connect. I believe Tablo is having an issue now. It does load fine with Mozilla Firefox, just not Chrome right now. Tablo had same issue a few months back. Try Firefox and see if it loads.

Same OG 4-tuner and Chrome 124.x. First noticed it last night.

Just the spinning circle, unless I’m on a VPN. Using the VPN, I’m home but connecting as from out of home, and it immediately loads. I’m able to do that at full quality with 2GB/2GB fiber.

But it works fine on Firefox and the Windows app.

We did get another extension for the latest version of Chrome but for some reason, it’s just not working as expected. It’ll take a bit of troubleshooting to figure out why.

In the meantime, Firefox or the Windows 10 apps are good alternatives.

1 Like

Any updates on this problem?

i turned disabled the chrome://flags setting for “Block insecure private network requests.” and am back to being able to use chrome. not a long term solution, but… it worked for me.

2 Likes

Did the same…Have all the menus, guide screens and video, but NO AUDIO!!!

Thanks! It worked for me. Have a great week.