Channel for Me-TV changes to ABC

My zip code is 19403 (Norristown, PA), and recently when I do a channel scan, channel 2-1 shows up correctly as Me-TV during the scan. But when I save the channel scan, it changes to ABC (which isn’t correct). Unfortunately this screws up the channel guide, because it is showing ABC lineup in the channel guide instead of the lineup for Me-TV.

This doesn’t affect live TV, as I can see the broadcast of Me-TV live. However, this ruins the ability to schedule any shows because the guide is wrong.

So I tried the typical work-around of using a different zip code that is near me, but the few I tried have the same issue. Me-TV changes to ABC when saving the scan.

Does anybody have any suggestions to solve this and is there anybody out there running into the same issue?

Same here. I am in 18041 so can receive Me-TV either from the Philly area on 2-1 or from the Allentown area on 69-3 which provides me the temporary “workaround” of rescheduling recordings to 69-3 that is likely not possible in Norristown. Although closer to Allentown the reception of 2-1 is a bit stronger here which is why I am calling this a workaround.

@MSR @ripa - We may have a fix available for this issue.

I’ll send you a DM with details.

Thanks for confirming the issue. I can get 69-3 where I live, so I can use that temporarily. Unfortunately the signal is broadcasting at 480p instead of the 720p you get with 2-1 channel.

Thanks for the quick response. Be aware that at least here the guide is also incorrect for channel 2-2 which is usually Grit but now shows as Laff. I assume it is due to the same issue reported for Me-TV but Grit is another that is available via another channel (61-3) in this area so the workaround is good for this one too.

I’m having the same issue at zip code 19460

I’ve started having the exact same issue with 2-1 scanning as METV but showing up incorrectly in the guide as ABC. Zip code 19087. Can you DM me the solution please.

The solution is to be sure you are running the latest firmware version, it was fixed by Tablo on their end, nothing I did on my end.

how long did it take them to fix the issue, here I am running ver. 2.2.40 and this issue is still there, waiting for tablo to reply to my request.