Can't watch live TV, Guide won't download, Edit Channel Lineup not working

I’m not currently able to watch any live TV. As of this morning, everything was working fine. Then, I rescanned for TV channels (having moved my antenna). When I scan for channels, it returns about 60 channels with 5 circles of reception.

When I click the “Add to Guide” button, it changes to the little thinking-spinning-circle icon. It stays that way for maybe 5-10 minutes, then goes back to the settings page. If I switch over to the guide page, the new channels are there, but the guide is totally blank, which means I can’t click on any live channels to watch. I can go back to the settings page and click on “Update Guide,” but it stays at “downloading: 0%” until after about 10 minutes when it seems to time out. The Tablo then disconnects with an error saying that the synching function failed.

I then power cycle the Tablo, reconnect, and click the “Edit Channel Lineup” button, where I get a screen saying “No channels were detected” and giving me the button to rescan. I rescan, and I again get a ton of channels, but I’m back to not seeming to be able to actually add the channels or get an updated guide.

Also, if I go to the guide and click on a channel (as opposed to a blank spot in the schedule), I get an error message saying “Player Error - Channel does not exist.”

Any idea?

I only have 7 channels, and my guide update takes several minutes, so it’ll probably take around 9 times as long for your guide to get updated.
My estimate is your guide will take around 30 - 45 minutes to update.

When you rescan, and add channels, the Tablo won’t work properly until the guide data has been updated, which explains most of the errors you’ve mentioned.

Go thru the rescan channel process one more time.
This when it takes you back to the settings page, wait there until the guide data update status displays it completed.
It actually goes thru 2 download cycles, but it will display it’s completed when it’s done.

Sounds like what’s going on with my unit. Started sometime yesterday afternoon. Opened a ticket and support is looking into it.

I rescanned for channels, removed some, added some, and now my guide won’t populate either.
It’s not just you.

Ah ha!
Changing my ZIP code to a neighboring one via the ‘Edit Location’ button, got my guide to download again.
Gonna switch it back to my actual ZIP code, and hope the guide still updates.


I left the Tablo for about 3 hours, and there still wasn’t anything populated in the guide, but it now lets me watch TV if I click on the channel part of the guide at the far left. I went to settings and changed my ZIP code and clicked Update Guide, and now it’s at 3% downloaded, whereas it was stuck at 0% before, so we’re making progress! Let’s see if it works!

Let us know how this goes - if the guide update fails again, send a note to our support team.

Man I don’t want to go thru this again.

I was finally able to get the guide data to download by selecting a nearby ZIP code, and letting the channel scan select my channels for me.
But it was the 3rd nearby ZIP code I tried.
The others failed, like my actual ZIP code.

After the initial guide data finished downloading, I editted my channel list to include the channels I really want, and the guide data successfully downloaded again automatically.

Probably never doing a channel rescan or manual guide update.
Did I mention never ever ever ever?

I spoke with Tablo support a few hours ago. We powered off both the modem and Tablo and after he connected to the Tablo he stated my modem was blocking it & guide would take 2 hours to download. 2 hours later still no guide so I followed Radojevic’s suggestion and changed my zip code. Within just a couple minutes my guide was back. Today was the first time I had rescanned since Tablo’s new update (2.2.14) so maybe there is a glitch with it. Just glad I have my guide back & a HUGE THANK YOU to Radojevic for posting here!

My problem was caused by corrupted guide information (or that’s what support told me). Changed zip codes, re-scanned for channels and selected channels in small batches and let the guide data download for them. Then went back and selected more channels and waited. Rinse and repeat.

Out of curiosity, either or you in Maryland / D.C.?

Sure you will…after the repack…:persevere:

In my case, my guide, set to my actual ZIP code, properly downloaded automagically every night.
It just doesn’t want to update, set to my actual ZIP code, or even several other nearby ZIP codes, after a channel scan, or when you click on the manual update button.
I kept changing the location ZIP code to a different nearby ZIP code until the guide finally started downloading.


I’m in DC and the same is happening (no guide updating). Working with support now. I suspect there is a new bug introduced with recent firmware since this hasn’t happened in the last couple of years. Either that or the guide data provider isn’t updating certain zip codes correctly. After support has had a chance to look at this for their own information, I’ll try the mnearby zip code suggestion. Thanks for the idea.

Incidentally there is a new beta being tested (I’m not on it) with some kind of speed up/improvement for guide downloading - so either they have found a previous issue they’re aiming to fix, or something was indeed introduced in the last firmware.

That is not beta, it is the current release, see below.

Release Notes for 2.2.14:
• Performance improvements when populating TV guide data, especially during setup or when adding new channels to the guide

I could be wrong - but I think there is a 2.2.15 beta also addressing the guide. Either way, you’re right that the 2.2.14 release notes suggest it may be the culprit on the guide not properly updating. (If there is a 2.2.15 beta maybe it’s trying to fix whatever has gone wrong.)

For whatever it’s worth, I’m having the problem without having done any channel or zip code change and without having manually updated the guide - the nightly updates just stopped adding further days’ scheduling though Tablo shows the overnight updates have occurred).


There’s been a change on our guide data provider’s end, which requires a change in how Tablo makes requests to update the guide. The existing firmware can still update the guide, but there may be delays. We can set you up with beta firmware which includes the change required to avoid any delays. If you get in touch with our support team, we’ll get that done for you.