Can't get WiFi set up

Just got the LITE, and have been trying to set it up via WiFi. Can get my phone switched to the Tablo_XXXX network, and then can enter in my home network and password. The app then says getting network credentials, and does so for 2-3 minutes, then gives me an “unknown error”.


1 Like

I believe that somewhere here another user had a similar complaint and it turned out that either their wifi network name or password had some special symbols (non-alpha/numeric) that Tablo couldn’t handle. I don’t remember what they were, just a suggestion for what may be happening.

Which Tablo app are you encountering this error on? If you try completing the WiFi setup on a PC, at, do you have the same issue?

The Tablo app for Android.

I haven’t used my PC because it’s not on wifi…it’s hardwired to my router.

Apologies for the delayed reply, did you manage to get this sorted out? If not, don’t hesitate to send our support team a ticket, or to give us a call at 1-844-TABLOTV (822-5688).

I got my new LITE yesterday because I finally had it with My AirTV and the same thing happened to me. I have the Verizon 5g Home Internet cube and everything in my home connects and works fine except for my new Tablo. I searched for solutions via Google and here and tried a few different things but nothing worked. To be clear, have no special characters in my SSID, funky router settings or the router set to weird wifi channels. However, I had to turn off Band Steering when I first got it over a year ago due to connection issues with one of my Rokus. Since I couldn’t find anything to help here or on the net I called the Tablo support number. My internet cube is in my home office on one side of my home and the outdoor TV antenna coax outlet is in the bedroom on the other side. After explaining what was going on to the CSR on the phone his solution was for me to either extend the TV coax to the other side of the house to the office or install a ethernet line from the router to the bedroom on the other side of the house to hook up to the Tablo. Unacceptable! Frustrated, I was about to call back and ask for an RMA to return the unit. Took a nap and thought about this and remembered that I had an old TP Link RE450 wifi extender with an ethernet port that I used in my old house. I set it up, put it into the bedroom right next to the Tablo and plugged in the ethernet cord to both devices and the Tablo came to life. It works great and I can even turn the settings up to the max of 10 Mbps with no buffering. Mind you, I am NOT using the extender to hook up anything except the Tablo. Basically all of this is to say where there’s a will there’s a way and maybe by my posting this here someone else might be able to get past not being able to connect their Tablo to wifi too.


That’s weird considering the Tablo is wired by Ethernet to the extender. Faulty WiFi on
your Tablo? Or is it behind a big obstruction that the extender is not?

Jury’s still out on the faulty wifi (IMHO I believe there is some strange networking handshake issue connected to the Verizon cube because the Tablo sees my network but just won’t connect to it) and nope on any obstructions. I found quite a few threads in this forum of others describing this or similar issues when I was researching and since I was a new forum member it said I couldn’t post a message so I just picked one to reply to and this was it. The extender has the ethernet port built in because it was designed for people to be able to connect a PC, an old smart TV or a game console without wifi capability.

The app then says getting network credentials, and does so for 2-3 minutes, then gives me an “unknown error”.

A few months ago I got a new unit and tried to set it up using android 12 on a tablet. got the same error 4 times in the setup wizard before it finally made it through WiFi setup. I’m using an old router so no problems with any of the newer WiFi features.

For each retriy I went to ethernet connect to then enable the add via WiFi feature, unplugged the ethernet and rebooted the tablo unit. This error is a pain in the ass.

For science I tried to connect the Tablo to the extender’s wifi today and the Tablo app keeps coming back and saying the wifi password is incorrect and to try again. This failure happened no matter how many times I tried. My smart phone (Android 12) is connected to the extender since it has to be in order to to access the Tablo via the Tablo app and I am typing in the password correct. I also tried it once again with my normal wifi network and the Tablo still responds with “unknown error”. :man_shrugging:

each time before I started the tablo app to connect to the tablo SSID I made sure the tablo app from the previous attempt had been killed off and the app data deleted. And since the error message is so clear it’s hard to say why it eventually worked.