Can't detect harddrive

I’m doing a new setup and tablo is not detecting my harddrive, WD elements 1tb. I tried a factory reset as well as updating firmware, I also tried using the other USB port, it still is not autodetecting. All the equipment is brand new. If I go to the setting menu and then to the harddrive section it shows that no hardrive is connected. The harddrive is powered up but the drive access light does not blink. I have connected this drive to my laptop and it autodetects on it. Any suggestions?

When you say the hard drive is powered up, is it powered by USB from Tablo or it has its own power cord? Have you tried plugging any other USB device into the Tablo USB ports? Your USB cable to your phone to see if there is any power.

Are you trying to use any other USB cable other then the short cable that came with the hard drive?

It’s a western digital elements 1 tb, it connects with a usb cable that also supplies power to the drive, when the cable is plugged in the usb port it provides power to the drive, thus it is not a faulty cable. the usb port is supplying power

Can you check if there is a firmware update for your drive, mate? My first drive was a WD Passport and I had to update the firmware on it. If there is not update, maybe the support people can help you out.

Try formatting the drive to a different file system? FAT32/exFAT for example… see if that helps…

I received this message from tablo support and followed the instructions. It worked!! I hope this helps others with the same issue.

Make note of the last step about the known bug, I believe I tested my rokus before I formatted the harddrive and that is what caused the issue:

Tablo Support - Tim (Tablo)
May 8, 3:55 PM EDT

Hey there,
Tim here! Thanks for reaching out to Tablo Support.

First up, I have a few steps to run through just to make sure the drive is being connected at the right time.

  • Unplug the hard drive from the Tablo.
  • Reboot the Tablo, and wait for the light on the front to stop blinking.
  • Once the light stops blinking, connect to the Tablo from the web app or the Tablo app on a smartphone or tablet.
  • Plug the hard drive into the Tablo.
  • After a few seconds, you should see a prompt on your screen asking you to format the hard drive.
  • Once the hard drive is formatted you should be able to see it in the settings page. It will show you the hard drive name (make and model), capacity, and how much is used (in blue) and available (in grey).

If this doesn’t work, we have a way of accessing your Tablo remotely so we can log in and see what’s going on - we’ll just need you to follow a few steps to put your Tablo in remote access mode. Make sure the hard drive you would like to use is plugged in. If the Tablo can ‘see’ the hard drive, we can format it for you.

It’s also worth mentioning, when it comes to your initial Tablo set up, this has to be done on either an iPad/iPhone, an Android tablet/smart phone, or in your browser (Chrome recommended). This is just for the initial setup, and you can add your other media streaming devices afterwards, but if you’ve attempted to set your Tablo up using a device not on that list above (you mentioned a Roku on the support form), that could definitely cause the issue you’re running into!

**_laed to the above, If you’ve first connected your Tablo to either a Roku, Apple TV, or Android TV box before one of the above mentioned devices, there’s a known bug in our current firmware that will prevent the format prompt from ever showing up. This will definitely be fixed in our next firmware update, but in the meantime, you’ll have to remove the Tablo app from all your devices and start from scratch with one of those approved setup devices I mentioned.

Run through that when you can and let me know if you’re up and running!

Take care,

Tablo Support Team
Moday to Friday, 9:30AM to 5:30PM EST