Cannot install Tablo App on 2nd Amazon Fire HD10

I have the Tablo App installed and working on a 2 year old Amazon Fire HD 10. Just bought a second Fire HD 10 for another family member and it will not allow the Tablo app to install, searching for the app on the Fire tablet and I cannot even find the app in the app store.

I tried going to Amazon’s “manage my devices” pages and for the new tablet it reports that the Tablo app is not compatible. How can it be fine on one tablet and a 2 year newer tablet be not compatible?

Any help would be greatly appreciated.

Search for Nuvyyo, it could work.

Are you in the US or Canada?

Also the Amazon account linked to that tablet, check the region is set to the proper country. This is best done in the browser on an actual computer.

“ To change your country settings to another supported country:

  1. Go to Manage Your Content and Devices.
  2. Open the Settings tab.
  3. Go to the Country Settings section, and select Change next to your current country.
  4. Enter your new address, and choose your new country. Then select Update .”

Thanks for the idea, it works on the older tablet. On the newer tablet the search results in a couple odd results, neither one is related to Tablo.

It is strange, any of the apps on the older tablet that I purchased cannot be seen on the newer tablet. And, the Tablo app cannot be found as Tablo or Nuvyyo.

I cannot seem to find the Country Setting, the new device is registered in the same name as the older tablet so hopefully it is for the same country, US.

On the Manage Your Content and Devices page, there is no Country Settings, there are only 4 choices, “Deregister”, “Delete voice recordings”, “Find your Tablet” and “More actions”. The more actions allows: Remote alarm, Remote lock, Remote factory reset, Set as default device, View device content.

Do you have multiple amazon accounts that can be associated with this device and the tablet is not set to the proper account.

Go to “Preferences” which is between “Devices” and “Privacy Settings”.

I just found that spot, and it is set to the US.

My only suggestion then is to factory reset the new tablet and set it up again like new with the same Amazon account on the old tablet.

No, we share the same account.

Did you possibly add the Google Play Store to the first HD10? I got one a year ago, and the Tablo app was not available as it came from the box. (My model HD10 features a USB “C” power plug.) Once I put the Google Play Store on it, Tablo installed fine and has worked flawlessly, even away from the house.

Installing the play store took around 15 minutes, and there are many articles on the web on the steps needed. The Amazon apps work right along side of the Google apps, and so far, I’ve only had one playstore app fail to play (and that was only after Amazon issued a system update for the machine.)

I was hoping to avoid that, the other user has already added a lot of bookmarks, and other preferences. Saying we have to do a factory reset could be painful.

BTW, adding the playstore on my wife’s 2-year-old Fire HD 8, and also on my Fire HD 10 left all of our bookmarks intact. It also allowed us to add Google Chrome to the tablets.

I have not added the Google Play Store to the first HD10, it is 2 or 3 years old and still has the older style usb power plug. The new HD 10 does have the “C” style power plug.

Anyway, I bought the Tablo dvr a month or so ago and the Amazon “app-store” did have the Tablo app so I have never thought to add the Google store.

To add a little extra confusion, I also have a 2010 or 2012 vintage kindle HDX that also refuses to allow me to install the Tablo app. It has other issues with battery life and I hardly use it anymore. But, it also will not find the Tablo app in the Amazon store and is also registered exactly like the other 2.

When I can get the newer HD 10 into my hands again, I may have to try the Google store.