Cannot connect from LG TV

Starting today, my LG Smart TV cannot connect to the Tablo. I am using the Tablo app on the TV, and when I try to connect I get an error “No network connection”. I can connect to all other services: Apple, Hulu, Netflix, etc. I even tried to connect using the LG web browser to and it just hangs at white screen, but can connect to other web sites.

The Tablo works fine from my Mac web browser and from my Roku.

It’s almost like someone put a firewall rule in place between the LG TV and my Tablo.

Any suggestions on how to resolve? For better or worse, I am stuck with the LG TV for a while.

1 Like

This isn’t immediately helpful for your situation, but in general,Tablo is moving away from support for smart TV specific apps. If you can use Roku in the interim, that would be my recommendation.

Sadly, after about 1 1/2 year, the app on my LG just stopped working. I get a “Check Network” message and error code 118.

If I switch to the browser in my TV, I can connect to the Tablo, and I can with both desktop computers AND my phone, just not with with the Tablo app on my LG TV. My TV is the UN7300AUD and it’s a 2020 model I think. I’m at my wits end… I’m considering hitting the big reset button on the TV as I assume it’s some sort of borked configuration file that I can’t access and that does not get wiped out when you uninstall the app and re-install (which does nothing). For now, at least I can watch the recordings and control the tablo using the built in web browser.

This is very disappointing. I have been using Tablo with my LG WebOS TV for over 4 years. It makes no sense for Tablo to pull the plug on something that works.

Yes, same thing here, error code 118. I went and hit the big reset button on the TV.

No good.

It’s so strange that I can’t even connect to from the LG web browser. If it’s a config file, then it is seriously borked.

Dan, can you connect to the network address? It should be listed in your router, something like

My router uses but some use If you can connect to that you’ll reach the server, not the page where you can use the device for whatever. Can you connect to with any other device on your home network? I’m thinking desktop computer, laptop, tablet or smartphone? If you can’t, then next is to make sure your router is detecting it and assigning a network address to it. If it is, but you still can’t reach it… it’s the tablo itself. In my case, I know everything is working except for the tablo app on the LG… I’ve contacted support, we’ll see what comes of it.

I will join the crowd and say, starting today, I am unable to connect to the Tablo from my LG TV. The Tablo is visible on the network. I can ping it just fine. It has always connected before and no changes have been made to the network.

It is a TV connected Tablo, and everything seems fine if I use the monitor connected directly to the HDMI (but that’s not where my TV is located).

So, are we saying I have to buy a Roku in order to use my Tablo? Really?

I would give support some time to figure out what is going wrong. I have an LG C1, and I get either a black screen or a connection failure when using the Tablo app on it now (I usually use a Roku, so I only checked when I saw this thread).

Hi all, we think we may have identified the issue, and it should be fixed now.

Can you all try the app again and post here if it’s working again (and of course also if it’s not)?


I think you identified the issue AND fixed it too. Yes, it is working again!

Thank you very much!

1 Like

Well, it turns out that Tablo’s serverside was out, thus no connection to “the internet”. It’s back up today and all is well on my LG TV. I got the following from support:

Tablo Support - Lauren (Tablo)

Jun 7, 2022, 10:08 AM EDT

Hi there,

Thank you for reaching out!

While this application is no longer supported, we do believe this issue occurred due to a server-side outage, the issue should now be resolved.

I hope this helps! Let me know if you have any other questions.

Thank you,

Tablo Support
Monday-Friday 9:30 AM - 5:30 PM ET


So there you go…

1 Like

It is working for me as well.

I wished I had seen this before spending a lot of time on it. I have a newer LG C1 and the Tablo app on the LG isn’t working. I usually use Roku Ultra but like having option to use TV app. It gets to the Discover Live TV and DVR page and it only gives option to “Search Again”. I rebooted everything including router, LG TV and Tablo DVR. Everything is on same network. I deleted Tablo app from LG and reinstalled. LG and Tablo are connected via Ethernet cable to same router. Works fine on Roku which is on same network.

The “smart TV” (not the Roku, Amazon or Android ones) proprietary platforms are simply a mess, a gigantic mistake. A greed grab that consumes power and does little more. Sadly found in TVs from two of the largest providers, Samsung and LG (who, in this case are battling for the last place IQ wise).

Just realize if you buy a TV from either, you’ll want a Roku or other alongside. Both Samsung and LG should be offering their TVs at a discount.

1 Like

So my LG had a software update recently and now the Tablo app on my LG Home page is now working. It looks pretty slick. Not sure if the LG update had anything to do with it or not.

I’m glad to hear the app is working for you on LG.

I agree with cjcox, the LG “smart TV” is the last LG I will buy. The apps are not as good as the ones on Roku, and every 6 months I have to do a hard reset on the TV to fix something (usually the network) which wipes out all the settings and logins. Just a big pain in the CENSORED. LG support and the user community are little help.

On the other hand, Tablo support is always fantastic and the community is small but very helpful!

My LG C1 77" has so far been a great TV and it’s one of the best OLEDs reviewed last year. I would never use apps as a deciding factor whether to go with a particular brand/model over the picture quality. I’m sorry you’re having other trouble that’s causing you to have to factory reset. I used to have a 75" Sony XBR that I had for about 4 years and they made me mad because they stopped updating the OTA channel guide. I did everything I could to try and resolve it but it just seemed it was no longer supported. That was when I went with the LG this year.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.