Bug in Windows 10 app- disappearing FF and RW (and a request for Win 10 app away-from-home streaming function)

Hi! I interact with my Tablo more often with the Windows 10 app than with any other interface. I just tend to watch OTA TV, including my recordings, on my PC instead of on my television. On playback of recordings there is a fairly consistent bug which causes the fast forward 30 and rewind 20 graphics to vanish from the PC screen. The functionality is still there… I just point my mouse to where I know they ought to be, and I can still FF and RW with a click in the area. But, if the graphic were more stable in the Windows 10 app, that would be nice.

When away from home, I would also like to use the Windows 10 app on my laptop to access my Tablo remotely, which functionality seems to be restricted to the Chrome browser. Again, I just prefer the Windows app to the Chrome interface when possible. I am not a Chrome user, so I use that browser only out of necessity. I would rather use the Windows 10 app, or barring that the Firefox browser.

I suspect the Windows 10 app does not get a lot of love and attention, but I for one use it most of the time, and prefer it! If I could live all of my Tablo life on PC within the Windows 10 app, that would be great.

Thank you, Charlie

You can also use the Edge browser to watch the Tablo.

These methods aren’t exclusive. I watch my recordings and streaming services on my TV via PC…

Media PC /HTPC the TV becomes the monitor… lots people just tend to watch on PCs – it’s a good thing.

Thank you ! I will give Edge a try.

Yes, agreed. In my case it is very convenient, although I use the Tablo apps on the streaming platforms with my Tablo sometimes as well (Roku, Fire TV Stick). For me it often depends on whether the rest of the family has control of the physical TVs, sending me packing to my study (and thus my PC & desktop monitor). The choice is very helpful to me in that regard!

1 Like

A clarification that I just checked… I can access and stream my recordings remotely using the Windows 10 app, but cannot stream live TV using the app. Live TV would be nice also, but the streaming of recordings functionality is already there, I should acknowledge that.

I use the Windows 10 app to stream live TV - you have to click on the channel number block (not the actual program name. See red arrow:

Remotely, Ron? As in, say, on your laptop and out of town? I can surely use the app to stream live TV while logged onto my own home network, using just the approach that you describe. However, I mean while I am away from home.

My apologies - I misunderstood. I haven’t tried to do it remotely except on my tablet and/or phone. I haven’t tried with Windows 10 remotely.

No problem at all!

We’ll take a look at this. Thanks for letting us know.


@chf1shercpa We weren’t able to replicate this. Is there a specific recording or set of circumstances you’ve found where this happens? i.e. is it always happening on longer recordings? Recordings from a specific channel? Recordings where you’ve used FFWD/REW frequently already during playback?

I will look for some commonalities and let you know if I see any. I have been using the Windows 10 app for at least a year and do not remember ever not having this issue- it has always been there for me. It may increase as you use FF and RW more during a particular recording, but I hadn’t really thought about it. It happens on pretty much all recordings, and most of the time/ at least half of the time. The circular arrows will just pop into and out of view as you mouse over them. Sometimes you mouse over a blank space and they pop into view, and sometimes they are in view and if you mouse over them they disappear, and sometimes they are in view and stay in view when you pass your mouse over them, and sometimes they are not visible and they stay not visible. But the functionality is always in place whether the circular arrows show or not. Click the spot, that is, and FF and RW work, graphic or no. I will pay closer attention to any patterns I can find and let you know more.

I confirm, that on both Edge and on Chrome, live TV streaming works remotely. I confirm that Firefox still does not, at least for me.

I had to bring my laptop back into my home environment to refresh the remote connections, and once I did that with Edge, it also worked remotely, just like Chrome has, and refreshing still did not enable Firefox to work remotely.

All three web browsers work inside the home network of course to show live TV and recordings (onsite, not remote). All three browsers will stream recordings remotely. But only Chrome and Edge will stream live TV remotely.

Doesn’t Firefox tell everyone it doesn’t support remote connect? …in the settings

I fiddled with it over the weekend and did find some commonalities. First, it seems only to happen when I first put the app in full screen mode. If I open the app and do not enter full screen mode, I do not get the disappearing semicircles and CC button (the CC button is also identically affected, I did not mention it before because I do not use closed captioning, so I hadn’t noticed… But the button is just to the left of the RR and FF semicircles and it acts in the came way).

As soon as I enter full screen mode, the RR, FF and CC buttons vanish if I hover over them. They may vanish temporarily, or they may vanish and stay gone.

If I leave full screen mode, the buttons are restored and behave normally.

If I then re-enter full screen mode, they stay normal, and do not vanish.

So it seems to only happen the first time I enter full screen mode. If I leave that recording/live TV session and then start streaming something else, it will follow the same cycle (starts in not full screen and buttons are fine, then if I enter full screen the buttons do the disappearing act, then if I leave full screen they are restored, and if I then enter full screen for a second time on the same stream or recording, they stay put).

Odd! I suppose I was just staying in full screen mode and never noticed this other aspect of the behavior before.

Anyway, I can make the whole thing stop by entering full screen, leaving full screen, and then re-entering full screen, for a particular streaming session.

Hrm… We’ve tried all of the permutations that you did and just can’t get it to behave the same. There must be some sort of system-level difference between the PC we’re using and yours… Or maybe the display.

I can recreate the issue on my Win10 app. As stated, it only happens when you first go into full screen mode.

I can also make the rewind or ff button disappear by going to full screen mode, clicking on FF or REW, letting the screen go back to normal (bottom bar goes away), and then moving my mouse to the bottom bar area. The button that I click on before will be invisible (you may have to repeat a few times).

Aha - we poked around a bit more and have managed to get it to do the same. We’ll file it as an issue so we can take a look at it next time we work on the Windows 10 app.