Bad USB cable from Tablo to Hard Drive

Kudos to Arash in Tablo Tech support!

My Quad has operated pretty much flawlessly for the last several months. A week or so ago, it developed a problem that looked like a bad hard drive. It would play a recording (or live TV) for about 2 minutes and then stop, giving an error code that looked like it couldn’t find the drive. The drive (and Tablo) were new last March. The drive is a WD Elements, 6TB. It had the same error regardless of playback device.

I rebooted the Tablo with no change. I rebooted the router. Same result. I tried a new power supply. No change. I unplugged the drive and it would play live TV fine. I tried a second hard drive and it worked fine. Sure looked like a bad hard drive.

I called Tech support just to see if the logs might verify the drive was failing and Arash said the drive (and the Tablo) looked okay. He said he suspected I had a bad USB(3) cable. I REALLY doubted that since the whole system just sits on a shelf with no movement whatsoever. How could a cable go bad just sitting there!!!

I took the cable off the test drive I had used earlier so with Arash still on the phone, I swapped cables. He tested again and said there were no dropouts. The system has again performed flawlessly for the last week or so.

The message in all of this is if you are having problems, don’t ASSUME the USB cable to the hard drive is okay. Mine WAS for a long time and then failed for no apparent reason. Incidentally, I tried the cable on a computer to look at the test drive and while connected to the computer, the test drive disconnected from the computer. I’m convinced!

The second thing is I want to publicly thank Arash in tech support. It’s that kind of support that makes the “Tablo experience” pretty darn good overall.



He and the rest of our support team are indeed pretty darn awesome. Thanks for taking the time to post such a nice message and glad to hear your issue was sorted out!