At the end of my rope

Tablo Connect is an unusable “feature”.

I’ve had work a couple of times , but it will no longer work. Tablo works fine in same WiFi, as soon as I switch to another connection, nothing. All I get is cannot find tablo. I have setup and reset up the connect “feature”. Says it’s paired and ready but will never find the tablo on a different connection. At this point is there anything else I can do? I am not fond of my tablo and find it is way more buggy and unusable than it is usable. I have tried my iPhone on Verizon network, I have tried my firetv on a neighbors WiFi. I have tried resetting and restarting over and over. Like I said at the end of my rope and possibly looking at other devices. Please help.

If you are saying it works fine when you are on the same WiFi/network, realize that you aren’t using Tablo connect in that scenario, you aren’t remote to your network.

Sounds like although you have Tablo Connect enabled that maybe your Tablo IP keeps changing or your port forwarding isn’t set up correctly (assuming you don’t use UPnP).

In addition to what Nilex said, you need to connect to your Tablo at your home with the device you intend to use when you are away from home. (For me, I connect at home with a Fire TV stick and have never had it fail when away from home). I would also recommend giving your Tablo a fixed IP address or reservation of IP address in your router settings, since your Tablo’s IP address may change if your router is configured to make dynamic IP address assignments. I would say that setting this up is not the simplest thing to do, but it does work great once you get it set up properly.

I do connect at home and on the firetv it says it’s paired. On my phone it shows connect is on. Both work fine at home but as soon as I leave home it will no longer work.

It is also on a static ip within the router. Even when I restart the router the tablo ip stays the same. Really baffled by this. Very frustrating.

I’d contact support. Something isn’t configured correctly it seems. Are you sure port forwarding is working/configured correctly?

Doesn’t say I need it. It has worked before without port forwarding.

Tablo Connect ALWAYS needs port forwarding. If you had uPNP enabled the router might have done it automatically.

My understanding was that if the tablo didn’t ask you to forward your ports it didn’t need to be done.

I would first confirm if you have uPNP enabled as @FlyingDiver mentioned above. If you don’t, your root issue is port forwarding needs to be configured…

So I decided to try to disable upnp and try port forwarding. My problem is even with port forwarding it still won’t connect.

What kind of internet service do you have? If your ISP is using CNAT you won’t be able to get it to work because of the double NAT (carrier and your router).

It definitely sounds like we’re missing a piece of the puzzle here. Is there anything ‘irregular’ about your networking setup that could be overlooked?

Based on what you’ve described, it sounds like the Tablo Connect feature is configured properly - but something is happening when you switch to a remote connection that causes the discovery and connection process to fail.

Are there any VPNs in play, or are the Tablo apps regularly being reinstalled, or having their cache cleared?

So after waiting for my support ticket to get processed I decided to get an hdhomerun and run it through plex. I now have no issues watching remotely using plex. Still have my tablo hooked up but I am not using it very much anymore. Tablo either needs to discontinue this ‘feature’ or fix how it works. I bought the tablo specifically to use remote when I am away from home, and I am disappointed. I’ve had the tablo for about 4 years and it worked ok at the beginning but tablo changed something and it works horribly now. I didn’t change anything on my end.

I am a combo Plex DVR and Tablo user. While we use Tablo as our main DVR for the household, I’ll admit, there are cases where remote to Plex DVR is a great benefit (e.g. being at the datacenter and logging in via a foreign device so we can watch the game while we “wait”… waiting being what we do a lot of when at a datacenter).

1 Like

Discontinuing a feature that works for the vast majority of people is a bit excessive. I would prefer to keep that feature since it’s always worked great for me. I’m happy to help you troubleshoot though so tell us more about your ISP and network setup.