Apple TV needs thumbnails while scanning

I’m loving the Apple TV app but wish it showed thumbnails while scanning (fast forward and reverse). Obviously, the main reason for scanning is to skip the commercials so it’s imperative to be able to see when commercial ends and the show begins.

Being able to use Seri to skip forward a minute or two is wonderful but its not possible to guess how long the commercial break is going to run.

Thanks for listening.

@sesweitzer - You should see FFWD thumbnails on completed recordings. You can read more about this here:

It’s not working! Thanks, That’s what I want but I don’t see thumbnails on any of my recordings. I have an Apple TV 4th Generation, a 4 tuner Tablo and some of the recordings are several days old. I also rebooted the box and gave it an hour to rebuild. Also restarted the Apple TV.

Maybe this is a bug since I’m using 2.2.11 I’ll report it there.

I so see the thumbnails when using the web app so they are being built but just not showing on AppleTV

My BAD. Turns out I don’t know how my Apple remote works. To see the thumbnails I needed to Pause the playback and then use the touch pad to slide forward with my finger. It works GREAT.

That’s still odd you have to pause first.

I think it may be something Apple changed in one of its OS updates. When I stumbled upon it I remembered reading something about it in a MacWorld Help article about things that had gone missing after an update. Lots of people were complaining that the Fast Forward wasn’t working anymore. It’s a MUCH faster way to scan now.

Looks like operator error. I’ve discovered all i have to do is press the track pad and that pauses the playback and then I can scroll through the video with the thumbnails. SWEET.

Hope my experience will help others.

1 Like

Have used AppleTV with Tablo for some time now and this is the second time I’ve seen my problem occur, always after Apple updates the ATV software. My use case is I watch a show WHILE it is recording because I get up after the morning news show starts and I want to be able to scan past commercials. Scanning a complete recording has thumbnails but these recordings in progress don’t. As I say, this happened (at least) once before (that I recall) and it took awhile for Tablo to get an update that restored these thumbnails. Fully recorded programs are NOT affected, only recordings that are still in progress, which is 99% of my use. Obviously, I rely on the thumbnails to skip the commercials, so when this is broken, I’m not happy. I have the latest 4K ATV now and the most recent ATV software that just added the Amazon video app. But the missing thumbnail has been with me for a couple of updates now.

Are you talking about in-progress or completed recordings? You will never get thumbnails on in-progress recordings. The Tablo doesn’t create them until the recording has completed.

And having the 4 tuner helps thumbnails get created faster. It does require a tuner.

I did say “in progress”. And this Tablo has created scan thumbnails during in-progress recordings at points in the past. As I said in my post, a couple of times now Apple has updated the TVOS and that seems to have broken this. Maybe it isn’t even due to Apple TVOS updates. Maybe it’s tuner load or something else. But it HAS worked. Having a 2-tuner model may be a major limitation but if I have to buy a new unit to resolve this, it will likely not be another Tablo.

Hi Joe - Before rolling out the tvOS 11 update, we discovered that Apple was indeed pulling the video segments from Tablo during in-progress recordings and extracting iframes (preview thumbnails) from them without having a completed playlist.

Something did change in tvOS 11. What that is isn’t clear as of yet. Since it’s not an actual supported Tablo feature, we haven’t had time to look into this thoroughly yet.

So it’s not the Tablo creating the preview frames. I thought that was the case. Interesting that the AppleTV is doing this on it’s own. Seems to me that there’s a conflict there. If both the App and the underlying video playback framework is trying to do previews, who wins?

Tablo won’t even attempt to create thumbnails on an in-progress recording. We need a completed playlist before we run the video through the tuner again to pull out the thumbnails.

(All the nitty gritty detail on how FFWD previews works is here: FAQs - Why Don’t I Always See Fast Forward Preview Thumbnails on Tablo? - Tablo TV)

If you’re thinking that the conflict is between the Tablo app and the player software, that’s a bit more likely but still not probable.

The likely reason is either Apple took that out of tvOS 11, or changed the way it does it and the way we feed video to the Apple TV player isn’t compatible with this ‘feature’ since the update.

My point was, after the recording is complete, won’t both the app and the framework be attempting to do previews? Or does the API know that the app isn’t going to provide them so that’s when it tries to do it on it’s own? I’m a registered Apple developer, but I haven’t looked at the tvOS playback APIs at all.

Ah… So FFWD preview generation is done via firmware on the Tablo itself. Not the app. The app just calls the playlist of previews if they’re available when you start playback.

In tvOS 10, Apple was extracting iFrames (thumbnails) from live (unterminated) playlists. The Tablo firmware nor the app would have been attempting to do that at all, so there wouldn’t be a conflict for in-progress recordings.

There hasn’t been any changes/problems with thumbnails on completed recordings once we pushed the post-tvOS 11 update so that’s not what the previous poster is running into.