Android/Google TV Tablo App Streaming Issue

I have a Chromecast with Google TV and an Onn 4k Android TV device sitting in my desk drawer. I hauled them out to make sure the software was up to date, remove apps no longer subscribed to, and install the Tablo app. I couldn’t get the Tablo app to stream for longer than ten to fifteen minutes before it would cut out with an error message. I ran the same test on a Roku on multiple downstairs TVs with no issues. The Tablo app on my Pixel 7 Pro and Samsung TV worked fine as well. I’m wondering if this is a wifi issue with those devices? Or maybe something else is going on.

TL;DR…
Check for Android OS updates.

While the newly installed Android Tablo app will be up to date, the Android OS will take a while to fully update.

The Android Tablo app works great on my 2 active Google Chromecast with Google TV (4k) units.
Both units have Android OS v12 installed with the latest security updates.

I also run 2 Chromecast with Google TV devices (1 wired and 1 wireless for reference) and have not had any problems with the Tablo app.

Having worked in IT for 35 years, updating the operating system, firmware, and drivers is always the first thing we do, followed shortly thereafter by rebooting the Chromecast, giving it a swift kick and a stern talking to… unfortunately, doing these things did not solve my problem.

While I am delighted for you, saying things like “mine works great!” is hardly relevant to my situation.

Sorry, I thought it was relavant.
Here’s something that definitely is, there are no exclamation points in my post.
I hope you figure it out.

1 Like

One thing to look it is how those devices are connected to the network. The only streaming device I had issues with was the Roku Express which didn’t work on 5Ghz (just 2.4 Ghz). It just couldn’t handle the highest quality settings on my Tablo.

So you might try to look at two things. One, see what the wi-fi connections are for those devices. Two, downgrade the Recording and Live TV quality to something like HD 720 - 5 mps and see if that works better.

thank you for the thoughtful reply. that’s why I wanted to sanity test Chromecast with Google TV, because it supports 5GHz wifi. Since the Tablo is my backup tuner to my Sling + AirTV, I have the quality settings set to 3 MB for both live and recordings. Based on your suggestion, I may try and connect it to just the 2.4 Ghz network and see how it does.

No luck using only the 2.4 GHz wifi. I also turned off the mesh wifi extenders. Still no luck. Back to the drawing board.

I also have updated everything and still fail to cast to all pretty much all gens of chromecasts. Tablo basically puts a black screen on the TV and keeps playing on my phone.

Started at least last September and nothing has helped.

I am in the process of buying a new solution for my home and may sell the Tablo to someone else I guess.

Can I ask why are you trying to cast from another device to a Chromecast when you can just install the Tablo Android TV app directly on a Chromecast?

evidently my problem was the cheap USB 2.0 stick I was using for recording. I pulled it and rebooted the Tablo and its working much better now. go figure…