Android App & Roku Channel

I have the new Tablo Quad - seems to be working fine, have not yet gotten a chance to fully test it yet.

Roku Ultra - Channel app request: For all backgrounds in the app that use black, please use 0% black. I have OLED tv and 5%-10% black wakes screen to try and “mimic” black when pixels should just be off (it just looks a little cheesey) not a big deal. Just a request if possible.

Android - app request: Have S10+, specs of phone show “Surround sound with Dolby Atmos technology (Dolby Digital, Dolby Digital Plus included.)” Does not seem to want to stream any sound to phone app if Surround option is checked. Unchecked and it works – but only on new channels in the same session - original channel will still have no sound (I guess until the tuner releases it, still buffering with Surround) it will work after closing the app and reopening, or waiting a little bit… Toggle surround back on, and no sound … Surround on works fine with Roku Ultra. I don’t see why it shouldn’t work with S10+ with surround? I tried to enable/disable Atmos same result - can’t find any option for Dolby or Dolby Digital. Unless this is AC3 it’s using? Something else?


1 Like

As another quick test you might download the ota2GO Android app (not an official Tablo app) and see if you can play back anything recorded with Surround Sound in it. Might help narrow things down a bit.

I agree with this test because 5.1 AC3 Dolby audio is different than Dolby Atmos audio. So while your phone can natively playback Dolby Atmos, that doesn’t mean it can natively playback 5.1 Dolby.

Many Android phones cannot playback 5.1 Dolby audio in AC3 format without using a different player like MX Player or VLC.

Had a chance to test the quad tonight:

Test record and watch live Yankee game.

what I noticed so far:

  1. No option in Roku Ultra Tablo app to “stop recording…” or “protect” while recording active program – option only available in android app? I stopped it from the app.

  2. Codec used on Roku Ultra app not so good. I flipped between true live ota input and roku ultra input, live looked way better. All settings on Tablo are at max. Game just looks ‘off’ streaming live to Roku Ultra… it may be the Tablo app though, looks a little saturated, too much brightness … little soapy/fake looking. Something just looks off about it (all motion modes disabled on TV, so it’s not doing any processing to the picture) - just so you don’t assume it’s the Roku itself: Same Roku input watching YouTubeTV or Hulu look just fine when watching a game. It reminds me of PS Vue’s stream/codec. When watching MLB/YES network and comparing between PS Vue and YouTubeTV, YouTubeTV blew it out of the water in picture quality … so I dumped PS Vue. The Tablo stream reminds me of the PS Vue stream quality for live baseball – something about it just doesn’t feel right. Using the same codec?

Android app on S10+:

So I recorded most of the game as a test, with Surround option on.

  1. Tested with ota2GO app: The recording played back just fine after downloaded and also when played directly from the Tablo. It didn’t use any external player as I didn’t install VLC or MX. When same recording played from the Tablo app – no sound. Actually looked way better then the Roku stream on the phone from ota2GO, I’d say identical to live ota quality. So the recording itself is fine, it’s the live streaming to the Roku Ultra that isn’t up to par yet.

Conclusion: Android app needs work on S10+ w/surround sound enabled (unless ota2GO is doing something to allow it to play with sound, but worked fine when played directly from Tablo via ota2GO – got no sound from official Tablo app). Roku ultra app needs some fine tuning to bring up the live stream codec quality, something is off about it right now. Maybe a higher MB/sec option? Strange the commercials and replays looked fine, less activity maybe. Actual live play is when it suffers.

Hope this helps the developers.

I’m slightly confused. How did it play directly from the Tablo just fine? And then not have audio?

ota2GO has an option to “play directly from Tablo.” on S10+: Played fine with sound.
Same recording played from official Tablo app on S10+: no sound.

Hopefully Tablo Support can give us some insight into this, if the S10 supports decoding 5.1 AC3 audio then I don’t know why it doesn’t work in the Tablo app.

As for the video quality, the native MPEG2 video is converted to h.264 video. The process is not perfectly lossless so you will notice a bit of difference. Some people say they don’t notice it all, some say it’s obvious. If you can’t live with the quality difference then Tablo is not for you unfortunately.

Understood. Not that it doesn’t look sharp at times, just a little off for live sport (hockey will really suffer). I think it can be tweaked (but Tablo must allow it) possibly a higher MB/sec choice for Roku app? 12.5 or 13.5MB/sec/1080i encoding or an all out no encoding “insane mode” option? :slight_smile: My Roku Ultra is in 4k 60hz display mode/deep color and my network can handle it if the Tablo can throw it.

You can’t not re-encode the video, no new Roku player plays back MPEG2 video. So if the Tablo recorded the native MPEG2 stream, you’d get no video on the Roku. Isn’t that fun lol

I wonder how high you could go on h.264 before Tablo processor suffers? I will be willing to test it :slight_smile:


Any particular reason there is no sound in the Tablo app on a Galaxy S10 with the SS feature set to On on the Tablo? Shouldn’t this be one of the newer Android phones that support 5.1 AC3 audio?


I agree with this, just make “black” screens black!

Roku Ultra App (bug): When a channel has no guide data it just populates the area with a bunch of diagonal lines [ /./././././././././././././././]

If you click on these diagonal lines to go to the channel, roku app crashes and goes back to home screen.

Only way to watch a channel without guide data is to click on channel itself.

We’re investigating this now. We’ve also passed along your feedback to our product teams.