Android app not working, everything else works

Hi all,

I am having the strangest problem with the tablotv box. Essentially I can connect to my tablotv from PC, Roku, and even the Android Chrome web browser but the android app would not work. It kept saying “No tablo was found on your network”. I tried this on multiple android devices (android phone, android tv box, firetv) and the same message appeared.

I have tried to reset my server, rebooted my tablo tv, delete android tablotv app cache and data. Absolutely nothing worked!

Thank you very much for your help.

Have you rebooted your router?

And have you deleted the Tablo app from your Android device, rebooted it, then re-installed the app?

yes, I did reboot the router and delete cache/data, reinstall the app. Nothing help. The most curious is why would it works with android google chrome and not with the app???

The other thing that it tell me to do is to add via Wifi to Tablo_XXXX but when I tried to look for a Tablo_XXXX, I cannot see any. Very Weird.

You only see the Tablo_XXXXX bit once, mate. Once you have set up the tablo with wifi, you won’t see that again unless you do the factory reset. (At least, that is my understanding.)

What is your adroid tv device model?

mine is an older model with 2 tuners. I purchased it in Aug 6, 2014.

Anybody who can help me out?

I have the impression that tablotv has a discovery problem in general. It may not be as reliable as it should be. For example, I VPN to home from work so that my PC at work is on the same subnet as that of the tablotv device. I can ping the device ( I can also browse to the device at and it would display the message “Nuvyyo Tablo Server”. However, when I try to discover and and sync it at, it always said that “No Tablo Was Found On Your Network”. I have read other posts on the topic which suggested to change lower the route metric, etc. None has worked.

Do you know if other broadcast network things work in your scenario? Might be hard to test from the Android device, but do you know if such things seem to work from other things you might have connected to the VPN? (e.g. a Windows host showing up on the Network Neighborhood… not that Windows browsing is necessarily a good test either).

great question cjcox.

The answer is yes as you can see from the attached picture of my file explorer.

. My home server ( is serving windows files. When I browse to \ I can see and access all my files without any problem.

Everything else in my network works just fine, except for tablotv :frowning:

Sorry about the followup… so without doing anything, your VPN host shows up on the Network Neighborhood for other hosts on the network? I say that because you used and I wanted to see the host show up in the browse list from the network master browser (done by election). Now, of course, I’m assuming nothing is being firewalled, etc. to prevent any of that.

No problem cjcox. Those are good questions. I am a network engineer working for many years in designing various type of routers so I can relate to your questions.

I am quite certain that broadcasting is working without issue. As you can see in my network view attached, the roku4 and Onkyo receiver (TX-NR509) show up in my work computer without problem.

There is no firewall on the VPN either. I can run Wireshark packet capture to see what is going on with the table discovery process but I just don’t know what type of protocol tablo use. If someone can give me some hint about it then I can get a packet capture in no time.

Only thing I can suggest is to pair the end device with your Tablo on the same network (apart from the VPN). That’s probably not what you were looking to do though. Maybe somebody else has some ideas?

At home with all the devices on the same network and there is no VPN, I got every laptop (windows and linux laptops) to pair, every roku to pair, I was also able to pair with the tablo device with the chrome browser running on my android box. The only thing that I cannot pair is the tablo device with the tablo android app. Isn’t that odd???

Is someone trying to fix the android issue. One day it working, the next it isnt. Even kindle is down. It cant even find my tablo.

I have no idea, but sort of scared to touch mine… don’t want it to break. :slight_smile:

Yeah, the android app is not yet stable. Not like the Roku app.

Some would say the Android app has more features that the Roku app.

@henry We hope to push out an update for this soon. What kind of Android box are you using? One other thing: if you head over to from any of these devices, do you have the same issue?

I use amazon firetv, LG g5 phone and matricom android tv box for accessing the tablo device. The tablo app doesn’t work on all of them. However if I open a chrome web browser and goto then that worked.

But I prefer to use the tablo app than the browser

I have resolved my android problem. What I did was to

  1. reinstalled my dhcp server
  2. retstart tablo device

after this I noticed that the android phone LG G5 and matricom android tv box started to work. The amazon FireTV was still not working. I then followed these instructions (RESOLVED - Fire TV software update - Tablo no longer usable) and the FireTV also worked finally. The process use Wifi to discover the table device, it only worked after I brought the FireTV to within 10 feet of the tablo device. Otherwise FireTV didn’t even see the Tablo_XXXX wifi network for some reason.