Android app always starts over

Not sure if this is expected behavior, but I see that when I watch a show on my Android phone, either one I started via Roku or started from the phone, but when I return it starts at the beginning. And I can’t just slide to about where I know I was watching because it insists on buffering everything, so maybe five minutes to get to a mid point, then if I don’t finish it and close I have to start all over again.

Are you using your phone over the WiFi that the Tablo is connected to or your phone’s LTE?

This is expected behavior if you are using Tablo Connect with an Android phone (and probably Tablo Connect with any device). Since it uses a 2nd tuner to re-encode the show for the appropriate bandwidth, it can’t save your spot nor start from any spot but the beginning.

If you are using Wi-fi on your home network, your Android phone will work fine with saving spots and starting from saved spots. And if you have a powerful enough phone and network, the “full quality” setting on Tablo Connect will make it look like your phone is on your local network (it will not use a 2nd tuner) so saving spots and starting from saved spots work fine as well.

1 Like

Snowcat, that is not what is happening. My phone is connected to same router on my LAN as Tablo (Tablo wired, phone wifi). When I open a show with multiple recordings, the oldest one shows about 50% watched (circle half full), but when launched I get on offering to resume, and it starts at the beginning, with all the buffering, etc. However it was partially watched via Roku, not the phone; are saved spots device specific?

No the saved spots work across all devices. I haven’t had any issues with the iPad, Roku 3, and Fire TV. The Fire TV app is based off the Android web app so I am not sure why you’re having issues.

“And I can’t just slide to about where I know I was watching because it insists on buffering everything, so maybe five minutes to get to a mid point, then if I don’t finish it and close I have to start all over again.”

This ‘buffering’ you speak of is very indicative of how the Android web app behaves when you’re watching something remotely, aka Tablo Connect. You should be able to slide to any point in a recording if the recording is being played back locally. I can confirm this behaviour on an Android tablet using the Android web app. Can you please do the following:

  1. Go to Settings on the Tablo web app on the Android phone and set the remote quality to Full Quality. Try playing an episode and let us know what happens.
  2. If the issue persists, humor us, and Turn Off your 3G/LTE data on your phone, and only leave your WiFi Turned On. Reconnect to the Tablo via the web app and try playing said episode again.

Before I did anything I tested what I posted earlier, and it did not behave that way; popped up spot on my last place. Did as you suggested above, and worked fine both ways. So then I went the other way; wifi OFF and mobile data ON, and it worked that way too!! Did I jump into a different universe today? How do I stay in this one, because the other one is very frustrating.

I am at a loss to explain what was going on; I cannot reproduce it now. Thanks for the indulgence, but looks like a non-issue.

Well is your Remote Streaming Quality set to Full Quality? That would explain the same experience both on WiFi and LTE.

I am having the same problem right nw (22 Oct 2015). If I am on WiFi at my house I can get the Android app to “resume” play OK. But if I’m on my phone’s data stream it will not “resume” This is EXTREMELY annoying and I’m starting to avoid watching things because this feature isn’t working. For some key shows I want to watch, I’ve started getting the recordings off the Tablo and putting them on my Plex server…Plex have no problems with resuming where it left off. Please Tablo give some feedback on this one! BTW, I have my remote streaming quality on my phone set to 500 kbps. This make any difference?

  1. What Android device?
  2. What version of the Android OS are you running on said device?
  3. What is the ‘Remote Streaming Quality’ set to?

@mjremijan - When streaming remotely Tablo must load the entire recording before resume can function properly.

Remote streaming quality is 500 kbps
Tablo version is 2.2.5

Phone: LG Volt
Phone model: LGLS740
Android version 4.4.2
Kernel version: 3.4.0+
Build number: KOT49l.LS740ZV6
Software version: LS740Z6

Resume does not and will likely never work for Tablo Connect (except full quality mode). This is not a bug. It is just a byproduct of having to transcode the recording a second time. If you are in full quality mode, Tablo Connect works just like you were on your local network, though not many setups can support that (need a very good upload speed for your home network and a a good download speed for your remote device).

1 Like

Thanks for the quick reply.

snowcat is right, when using a remote streaming quality that is less than Full Quality, then resume feature will not work because the Tablo has to re-encode the video on the fly (aka transcode) to the lower bitrate (in your case 500 Kbps).

  1. What is the upload speed of the internet connection where your Tablo is hosted? If this is too slow, you may not be able to use the Full Quality as the remote streaming quality setting.
  2. What is the Recording Quality you’ve set the Tablo to?
  3. Your smartphone, what is the provider and its 3G/LTE download speed?

Ok thank you. I changed to Full Quality and “resume” works fine. Thanks for the help!

No problem. Full Quality will result in buffering issues if your internet’s upload speed is not fast enough though.