Amazon FireTV Constant Disconnect

A couple days ago the Tablo App on Amazon FireTV box started displaying an error message within 1 minute of watching a show that it “Failed to load video” and gave options for Retry (which never worked) or Cancel. It would then give an error that it lost the connection but would go back to whatever menu you last had (recording, live tv, etc).
Now this issue is every time we try to use the Tablo app on amazon FireTV. It’s rendered the system unusable. I have rebooted the Tablo, Forced Stop, Cleared Cache, Cleared Data, as well as uninstalled and reinstalled the app on the FireTV box. (I’ve done all these steps individually and none have worked).

Anyone else have this issue??

Also, the tablo app and tablo box work perfectly fine when I use the app on my iPhone. This issue is isolated to the Amazon FireTV box.

I have the tablo wired into a router and a hard drive with its own power supply connected.

1 Like

I don’t use the box but do use the standard Firestick and the 4K Firestick. When either starts to act up, I go into the menu (for the Firestick) and FORCE STOP the Tablo app, then clear the cache and then clear the data (which probably removes the ability to connect if you are remote) and then restart the app. After that, it works fine again. Might give that a try if the box has that capability available.

Have you rebooted the Fire TV?

Thanks for the feedback, Steve427 the theuser86. Unfortunately I have tried all those things and it doesn’t resolve the problem. I’ve even removed some apps from the FireTV just to free up memory thinking this might be an issue with caching the shows we’re trying to watch. But nothing has worked yet.

I’ve added these details to the original description of the issue just to

The only other thing I could think of would be to do a factory reset on the FireTV box (if such exists). You’d have to reinstall all your apps but that would put the FireTV box back to as received condition and if that didn’t fix it, I’d contact Tablo support to see what they say.

Is your Fire TV on Wi-Fi or Ethernet.? I’d be curious to hear if you have these same issues on a hardwired connection. If this doesn’t yield any results, don’t hesitate to give our support team a shout, we can take a look.

I ended up doing the factory reset on the FireTV box and that seems to have resolved the issue. I should have done this earlier when I realized that the iPhone and Android apps were working, but FireTV was not. I was just trying to avoid a factory reset and maybe hoping others had the same issue resulting from a recent version update… but that’s not the case. Maybe it was just a good old fashioned gremlin in the system causing problems. Thanks everyone!!


Not your intended use of the word but it brought back memories…

I was expecting:

Glad the factory reset did the trick!

1 Like

Welp, the solution of doing a factory reset didn’t hold too long as the issue is back. So, I’ve done the factory reset on the Amazon FireTV, I’ve rebooted both the Amazon FireTV and the Tablo, and I’ve done the whole ‘delete cache,’ delete data,’ and force stop. Nothing has worked.

The streaming to my iPhone, iPad, and Android tablet all continue to work fine. It’s isolated to the Amazon FireTV.

Any other thoughts?

Is your Fire TV hardwired with ethernet cable or are you using Wifi?
If using wifi, try connecting ethernet to the Fire tv box.

If the reset isn’t lasting long, I’d suggest a call to support and see what they suggest. It sounds like a problem with the app and maybe they have a solution.

Thanks KirkH for the idea. I could stretch a cord over to it and test it, but at the end of the day the FireTV box is in a place where it needs to be wireless.

I think you’re right, Steve427. I’ll give them a call next time it acts up and maybe they can grab log files from the Tablo or FireTV. My purpose in posting here was to see if anyone else was having this issue and it appears it’s isolated to me. :frowning:

I know you said you rebooted your Tablo and Fire TV, but did you reboot your WiFi router throughout all of this?

About 2 weeks ago I stabilized my home network by upgrading the modem and during that process the mesh router system was rebooted several times. Since then, the modem and router have been rock solid and haven’t needed a reboot… but for good measure I just did a reboot of them both. We’ll see how it goes.

I don’t think it’s anything to do with the modem, router, Tablo device, or hard drive connected to the Tablo because even when the Amazon FireTV errors out, I can play Tablo movies/shows on my iPhone, iPad, and Android tablet without any issue.

I have the same problem and it appears to have started after I updated the software on my Firesticks a few days ago. I have 2 Firesticks (4K version) and both have this issue. I also use the Tablo app on a Roku stick, multiple PCs, and an Android phone and none of these have this issue so it’s clearly an issue with the Firestick. I was about to try resetting my Firestick, but I see you already tried that without success so you saved me the trouble. Have you opened a support case with Tablo about this issue?

FWIW, I use the 4K Firesticks and have had no problem. Well, I should say no more than usual. Every once in a while, the Firestick will have issues with Tablo … buffering, voice sync errors, etc. I have found that forcing a stop of the app and clearing of the cache and it’s back to normal for days or weeks. No more issues with 2.2.30 than I had with 2.2.28.

I ended up replacing the FireTV box with a FireTV Cube on Amazon Prime Day. I probably should have dug into it more, but I figured with the upgraded memory and cpu on the Cube versus the Box, I was likely fixing the Tablo problem along with getting more current. And so far I haven’t had any issues with the Tablo app on the FireTV cube. It even brings up the interface faster and retrieves the data from the Tablo much faster.