All recordings on Tablo internal storage deleted after I plugged in an external storage device

I had recordings on the Tablo internal storage. Storage capacity was getting full so I decided to add an external USB drive of 64gb. It formatted fine but I just discovered that all my recordings that were previously stored on my Tablo are gone. And the only storage I see in the settings is the external USB drive. I do t even see the Tablo drive capacity anymore. Is there any way to retrieve my previous recordings? Is this a bug and if it is please fix it. Thanks.

Since I don’t think tablo supports external USB drives, I would unplug the unit, unplug the USB drive, power on the unit, and see if the recordings magically reappear.

Another cross your fingers, maybe will come back after tonight’s update/maintenance connection.

1 Like

Tablo does support up to 8TB USB drives. The internal drive can’t be seen when the external drive is plugged in.


I really meant flash USB drives - non hdd/sdd. And those are the ones I know of in the 64gb range.

It’s a 64gb USB flash drive. Strange that both storage pools (internal and external) would not be shown. I’ll try unplugging the external flash drive and see what happens? Does anyone know if the same thing will occur if I use an external usb SDD/HDD? As a side note, what’s even stranger is that upon taking another look, not ALL recordings were “deleted.” I can see some of my prior recordings but not all. Makes no sense.

Flash drives are very slow in this device. I would first try a reboot to see it the old times show up. If you take out the flash drive and then reboot, you will lose all take access to that drive.


According to this support post, “If/when you attach an external storage device, you will still be able to play and delete recordings on the internal storage but all new recordings will be sent to the newer, external storage you have attached.” But it wouldn’t be the first time Nuvyyo promised something it couldn’t deliver.

And this article only applies to gen 4:

To expand the recording capacity of the 4th Generation Tablo, simply connect a portable USB hard drive between 1TB - 8TB to the Tablo’s USB port.

It doesn’t apply to USB flash drives or drives less then 1TB.

This is what I’m seeing. Apparently the drive is recognized.

Apparently, some older recordings were sent to the USB drive but not everything that was previously on the Tablo internal storage. I’m going to try a reboot later tonight to see if that makes a difference. I also don’t understand why you have to use something between 1-8 tb for external storage? Why not something smaller?

What makes you think they’re deleted?

The only storage amount you will see is whatever is connected to your Tablo. If you used 100G internal, the second you format the external, you’ll only see that total. It does not combine available or used memory of the two drives.

IDK why they say not to use smaller than 1T drives. I had used a flash drive and it worked very well, but for two things: I couldn’t play anything if I was recording more than 2 other things (nonstop buffering); I could only keep recorded episodes UP to two weeks ago, even if Auto-Delete was off and Keep All Episodes was on. The only way was to Protect each file.

So, are you saying that because you can’t find recordings? Or because you see only a small amount of used space?

1 Like

I’m saying they’re deleted because they’re not in the list of all available recordings. They were all there prior to plugging in the USB drive. Now, some are there but not the majority of previously recorded shows. I just rebooted (unplugged) the unit and now I can’t find my tablo. :joy:

Give it a few min and then try a reboot instead. The full power of and unplugging takes forever to buy back up.

To reboot, press the button on the button of the Tablo once, quickly.

Just try again or hit view connected for a few and see if you get anywhere first.

1 Like

I rebooted again and this time it worked. Just to test things out, I removed the USB drive and the majority of my previously recorded programs are gone. I’m only seeing programs recorded within the past few days. So, it looks like my programs are gone. A warning to others who plan on using an external drive, watch everything you recorded first or you may find that they’ve been deleted upon plugging in an external drive. This should not be happening. Can anyone from tech support chime in?

… you know that whatever was on the USB thumb drive won’t work in the Tablo now, right?

I’d never heard of this happening but TS did tell me there could be disastrous results by using a flash drive. Mine was just a little different than yours!

I’ve swapped out disks on my 2-tuner 3x (usb flashdrive, older hdd, new ssd), as well as added a new hdd to my 4-tuner. I have not lost a single recorded episode. This has to be very frustrating and maybe you should open a ticket to see if they have any advice?

@RD4 had wondered if things would work themselves out during the nightly maintenance, but it’s likely that whatever’s gone is gone for good now.

It’s possible that by submitting a ticket, they would be willing to look at your device and see what happened. But it’s also likely they’ll give a generic answer of “You used an unsupported external disk”. (The support pages do state to not use it.)

I wish you luck and hope that things do work themselves back. How does your storage on the internal drive compare now?


What’s funny is that whatever was on my USB drive is now mirrored on the Tablo internal storage. Makes zero sense. I have a call to tech support now and we’ll see what they say. I may very well get a canned response to not use a USB drive and use a SDD/HD instead? It makes no sense to me whatsoever as to why we can’t use any type and size of USB storage system? As long as it’s able to be formatted properly (which Tablo did automatically when I plugged in my USB stick) it shouldn’t make a difference.

Makes me wonder if it ever fully recognized the drive and you ended up recording to the internal instead. That would mean that your old recordings were being deleted to make space for new ones.

1 Like

I’m pretty sure it recognized my USB drive. There was still plenty of room on the internal prior to plugging the USB drive in. There were only 3 shows that recorded after I plugged my drive in. I was reading other posts and apparently the “reason” that Tablo doesn’t recommend USB flash drives are that they can be slow and wear out quickly. Yes, that’s true to a point but there are flash drives that are made specifically for video recording and playback. And flash drives are much faster than mechanical HD’s. It’s too bad that the internal storage of the Tablo is disabled once you plug in any external drive. Anyway, haven’t received a callback from tech support as of yet but I think I have my answer. I’ll just use a larger HDD next time if I want the external storage.

What YOU did not mention unless I missed it is did you get a message to format the USB drive? If you did not then I would think it may not have been recognized.