Ability to reboot the Tablo from the app

Especially with all the Gen4 issues on ROKU, there needs to be a reboot option in the app. My Tablo is upstairs from our normal viewing area and it’s getting to be a real PITA to walk up and reboot it. I’ve only been up and running for just over 24 hours and am close to giving up just on this lack of capability alone.


I plug my tablo into a remote controlled switch. I can turn it on or off with the Alexa app. There are several on Amazon that would work great and they are inexpensive. That would beat going upstairs every time you need to reboot.


This is the second time this feature has been requested and I still support the option. The answer seems to be that if the app and Tablo aren’t communicating, then it’s unlikely that the app’s restart option will do any good. (Yeah, I thought it was BS as well.)

@wkh has a great idea for solving that, but I went another way. My most annoying Tablo to get to is plugged into a dumb plug with a remote, so that might be another option.

I can’t name how many times I was rebooting and unplugging my Tablo those first couple of months. Lately, though, I’ve only had to reboot them to remove a hard drive or unplug to move an entire unit. Once you get your setup more finalized, I hope that you don’t have to reboot as often, either.

Is there any particular reason that you find yourself rebooting the Tablo so often right now? Is there some setup or other problem we can try to help with?


The latest was adding a hard drive. Even though some channels played after the format it required a reboot as some stations just went to black screen when selected.

And as I said, there appear to be many “glitches” in the ROKU interface. I find a reboot at least restores functionality. Seems like a LOT fo the configuration edits only really take hold after a reboot so I’ve kind of adopted the change/reboot as a best practice for now.

I’ve not yet seen the app completely lose contact with the Tablo so I too think that excuse is BS. Besides, even if it did happen, that doesn’t minimize the benefits for when it doesn’t :slight_smile:

1 Like

I had a similar experience after adding a drive as well. I wonder if @TabloSupport has any idea that the Tablos have odd behavior if you don’t reboot them after formatting the new drives.

The Roku is a mixed bag right now. I’m sorry you have to go through the whole process of rebooting your Tablo to get it up and running. I’m assuming you’ve tried rebooting the Roku when this happens and had little luck?

1 Like

Yes, when my new Tablo being used with the Fire Stick 4K MAX got stuck in playback, what fixed it was restarting the Fire Stick. For me, most problems seem to be coming from the apps, not the Tablo itself. Your mileage may vary :-).

1 Like