4th Gen Surround Sound

I might have missed this setting before. But, I recently noticed surround sound pass through is an option. Do you have yours Enabled, Auto, or Off? I have two tv’s that both have Chromecast with Google TV plugged into HDMI. One tv has optical cable hooked up to soundbar. The other tv has hdmi arc hooked up to soundbar. Would Auto be the way to go?

I found the surround sound setting used to depend on which device/app combination I’m using. However, after recent app upgrades and firmware upgrades, the Auto setting now works on the Google TV Tablo app although the slight startup audio delay on the Google TV Tablo app is still there. So I set the surround setting to Auto on both my Amazon Fire Cube and Google TV now.

Keep an eye on that setting, though. I’ve noticed after app updates as well as firmware updates, that it’s returned to it’s default of OFF.