2nd Generation Fire TV

I note you have not tested the 2nd generation Amazon Fire TV. Do you know when you plan to do so,? I have been unable to get the Tablo App on my 2nd Gen Fire TV to recognize that there is a Tablo on my system. All my other Amazon devices access the Tablo correctly.

For my 2nd gen Fire TV, I have tried downloading the version 1.3.3 app from the Amazon app store, side loading the version 1.3.3 app apk sourced from APKPure.com and tried side loading the the version 1.1.8. I have tried using both WI-FI and Ethernet connections for all these app versions to no avail.


The 2nd generation FireTv has been tested and used by many Tablo users. The only thing that hasn’t been tested yet is the 2017 FireTv dongle.

My apologies, I am talking about the 2017 FireTV
Dongle. My existing 2nd Gen and Fire Sticks work fine with my Tablo.

Gotcha. In another thread, the Tablo folks have one of those on order and should be testing it soon.

We’re still waiting on the new FireTV to get here - but one thing you can check is the IP address of the FireTV.

Compare it to the Tablo’s IP address; are they on the same subnet? E.G does one have a 192.168.x.xxx address, while the other has a 10.0.x.x address? This would cause issues with discovery.

Thanks, but they are on the same subnet. The only differences in their IP addresses is in the last three digits. The other Fire devices I have that are accessing the Tablo are also on the same subnet.

1 Like