1080i stream playback issue with Chromecast

I searched through the forums and didn’t find anything on the specific problem I’m having, so here goes…

I have the 4 tuner Tablo directly connected to my home network via ethernet cable. I have a Chromecast on all 3 TVs which I use to playback Tablo content. Whenever I cast either live TV or a recording from a 1080i channel, the video starts just fine, but then after 2 minutes or so, pauses to buffer, then endlessly loops between trying to start again and dropping back to buffering. It only happens when casting - playback directly on my Android phone or computer are fine. I have tried directly connecting the Chromecast with the ethernet adapter - no difference. I have tried swapping hard drives - no difference.

Again, this only happens on channels or recordings from channels that are listed as 1080i in the settings. I’ve read that trans-coding 1080i with a 4 tuner Tablo was problematic for a while - was this ever fixed? Could this be related to that issue?

What are Tablo’s settings for “max recording quality?” I tried from the recommended 720p upward for more than a few minutes while casting from my Nexus 7 tablet to a Chromecast (1st gen; is yours the 2nd gen version?) and didn’t see any buffering issues. Obviously, the higher the max recording quality, the better your router should be at slinging that data. 10 Mbps doesn’t sound like a lot but if a lot of things are going on (like traffic and interference), you could run into issues.

There might be throughput/signal issues if the Chromecasts are too far from your router or have obstructions. A good way to generally find out what the throughput/signal would be is to use a mobile app utility that tells you those stats at that location. (Many vendors make apps for their routers that have such a utility.) For example, my Netgear Genie app tells me i get about 72 Mbps with 100% signal strength in my bedroom (over Wireless N) while I get slightly less in my kitchen at about 65 Mbps with 95% signal strength.

I have the Max setting at 1080 8 Mbps. The recommended 720 5 Mbps got a little blocky at times. I don’t think this setting is the culprit though as it only happens on 2 of the 30 plus channels. Also, I mentioned that I connected my Chromecasts (all gen 2) with Google’s ethernet adapter, so throughput really shouldn’t be an issue. In fact, since adding those ethernet adapters, buffering delays on the other channels are much shorter - I can definitely recommend the ethernet adapter for Chromecast as it does improve the overall experience.

But back to the issue at hand - this is really the only problem I’m having. I’ve got to resolve it though to have any chance of convincing the rest of the household that cord cutting is a good idea. BTW I’m on the latest firmware (2.2.8 I think - I’m not home at the moment).

I think the Chromecast is rubbish technology, and suspect it can’t handle that big hose pipe stream of video that it is getting.

You say you don’t think the problem is the recording quality setting - have you tested it at lower settings to confirm? Before they changed to numbers of mpbs for the recording quality, the 3 mpbs setting was called Roku-Chromecast.

1 Like
  1. HD 1080 - 8 Mbps is not the Max quality, HD 1080 - 10 Mbps is the Max quality which is likely way too high for the Chromecast. Read the link below please.
  2. HD 720 - 3 Mbps is the recommended setting for Chromecast users. I quote “Users who have smaller hard drives may also want to explore this recording quality option as it still provides great picture quality but only requires 1GB per hour of recording. It’s also great for people who use ‘stick’ style streaming devices like Chromecast.”


I’m new to Chromecast and so don’t want to make any claims I can’t back up, but I also have PlayOn running and have casted movies in full 1080p to the Chromecast without this kind of issue. However I have moved the quality setting back down to 5 Mbps and will test with that.

@theuser86 I know the maximum setting is 10Mbps, but I was asked where my Tablo’s Maximum quality setting was set.

Let us know how it goes on the 5 Mbps setting. Even give the 3 Mbps setting a try if you want to humorous us.