Wrong shows are being recorded on schedule

My Wife has General Hospital set to “record all new”. She discovered that (around the firmware update) the shows being recorded while labelled as GH, are not. Same channel, but hours out of sync.

For a test, I tagged a sitcom to record, and when I checked the recording the next day, it was not the right show.

The Guide shows the correct time, and the shows listed match what we watch on live TV.

I also noticed a couple of shows I test-recorded disappeared from the listing. I noticed another thread about this bug.

Is my problem related?

The guide data for said channel may be wrong? As in the Tablo recorded the show at the correct time based on the info in the guide, just that wasn’t the actual show playing.

Have you confirmed with an external source what time said show airs?

Thanks. All the shows listed are what is playing now. I will tag a show to start recording in 15 mins then check the channel from a TV to verify what is on that channel.

However, GH has not changed channels or time slots for many years. So your theory does not cover that observation.

Anything is possible with the Tablo guide data, it could be wrong. So unless you knew for sure exactly what was playing then it’s hard to tell for your GH example.

A good way would be to open a Support Ticket directly with Tablo and have them look at your logs to see if the recording occurred at the right time.

Well, first lesson is how fickle OTA signals can be! I had Ch 2.1 set to record Entertainment Tonight.

When I tuned to the channel 5 minutes early to monitor, I found it was not coming in very well. Lots of pixelation and drop outs.

So I set up to record Time Team on TVO 19.1 - always a super strong signal!

So far I can confirm the show broadcasting is indeed Time Team. Its an hour show, I don’t know of any way to verify its recording before its done.

Well you can go to the Recordings section, and start watching the recording before it’s completed. It will start from the beginning.

Ah, neither recording is there. But this could be that known “missing recording” bug.

Yes, which firmware on the Tablo are you running?

Can you check multiple devices, say iPhone, tablet, PC, Roku, Fire TV?

I just checked my Tablo, The Big Bang Theory is set to record from 7:30 PM to 8:00 PM. It started recording with the flashing red channel call sign "9-1 CFTO"in the Live TV guide. Then I went to Recordings, and the episode is now listed under recordings for me to start watching. That is all 1 minute after it started recording.

What is your software versions?

Mine are:
Tablo: 2.2.2
HTML Application: 1.0.21-542

I’ll Use Tablo Ripper to see if I can recover the recording after 8.

1 Like

Yes, I have tried setting up recordings from:

  • iPad app
  • iPhone app
  • Android app
  • Safari web browser (on a Mac Book Pro).

I have tried viewing the recorded shows on:

  • Android app
  • iPhone app
  • Safari web browser

Although not tested today, yesterday the iPad app seemed to be more reliable showing what recordings were present. And in the Android app (yesterday) it seemed changing the recording view mode could cause some “missing” recordings to show up.

Today I’m just using Safari to record, check recordings and view the schedule. I also have Tablo Ripper on a Windows 7 machine to see what recordings it can recover. So far zero.

This may be an indication this is a bug of some sort: In the Schedule list, my two test recordings are there, with a “1” in the top right corner. But when I open them (click on them) my recording instance is not listed!

Its like my recording event only half exists.

I’m going to give this a rest for tonight. But in 24 hours or so I’ll check to see if bogus recordings have appeared overnight.

Aha! As I suspected, the test recordings are in my “recorded shows”. But they are NOT what I asked for!

The 2.1 recording says its Entertainment Tonight 7-7:30 pm Oct 5. But it is actually 2.1 5am to 5:30 Oct.6!

I know because it happens to be a newscast with a time stamp and the show started with everybody saying “good morning”.

The TVO (19.1) recording is there, it says “Time Pilots” Oct. 5 7pm to 8 pm. But is actually “The Agenda” where they interview Mr. Broadbent. I know that aired last night, but likely repeated a few times afterwards.

I also asked for “The Muppets” Oct. 5, 8:00 pm to 8:30pm on City (57.1). Its actually City 6 am to 6:30 Oct. 6. Verified because that is Breakfast Television’s time slot and they have the date/time in their banners.

And I asked for “Life in Pieces” 57.1, Oct. 6, 8:30 pm to 9 pm. That is BT 6:30 to 7 am this morning (Oct. 6).

So what causes a 10 hour or so time shift?

Are you scheduling any of these recordings from devices that do not have the correct time set? Say the Roku?

Open a Support Ticket, let Tablo looks at your logs. Serious bug.

Yeah, I opened a ticket last night, and included a link to this post since we are covering a lot of info they will likely want to know.

I scheduled recordings from the Android app, my Mac book pro, iPhone and iPad. Everything appeared to have the correct time. That is, the guide display had the correct time in the corner and it matched the device’s time. It does make one wonder if some underlying sub-system has the wrong time.

When I first got my Tablo it could not connect because it could not get a time update. My upstream ISP (Bell) is blocking the NNTP port (123). My provider (Acanac) has created their own time server, but its using a manual address. I was able to add that address to my Android player, but there is no provision for the Tablo to use custom NTP servers. Support remoted in and did something, likely a manual date/time set. I wonder if my upgrading the Firmware trashed that?

Just to wrap this thread up, my problem was the low-level date/time was set wrong.

This is caused by a problem with NNTP servers on my ISP providers network.

Table has been manually connecting in service mode to set the date/time. But after a firmware update the change is lost.

Having said that, I think I saw mention someplace of a fix in the latest firmware. Or maybe a work-around. Either way, I should be OK next update.

Rich.