Web app on Android phone didn't FF/30 even after update

We watched some TV tonight - well, recorded shows. Two of them One was an older Daniel Boone show my wife had recorded and the station was a x-3 broadcasting at what, 480P ? So low resolution or whatever I played it through my computer to the Chromecast. Twice it went into buffer mode for extended periods.

We got disgusted so when that show was over we tried a phone, again for those who missed it, a newer Moto X Android 4.4.2 and the latest Tablo web app. I launched Tablo and I noticed the phone was doing a download - it said it was downloading Tablo player, did I want to install, etc… Yes. When it was finished nothing great or new, it STILL refused to fast-forward using the FF tap. As I have outlined here a couple of times before all it does was pause the images to a still, mute the sound, and then after a few seconds it picked up as if all you did was leave the room for 6 seconds. I watched closely and it paused the image, the counter went for 6 second and then started playing again. Instead of FF 30 seconds it muted sound and froze the image for 6 seconds and then resumed. In other words if there would have been 3 minutes and 0 seconds of commercials, tapping FF/30 6 times would have taken us 3 minutes - so you gained nothing, it never actually "jumped ahead.
So the cats want on my lap, one jumped on the table next to me and tried to change shows. I moved the phone and noticed that as phones do the screen went from the normal portrait to landscape view. Most folks hold their phones in the natural human hand position, portrait position unless surfing the web, etc.  - it is made to fit the hand better that way (stick with me, I’ll get to the why of all this soon)
I picked the phone up so Koko didn’t pause the show and it was STILL in landscape mode. The show went to commercial at that moment and without thinking I tapped FF. WOW, it jumped ahead exactly 30 seconds and skipped the first commercial!
So I put the phone back in normal mode - normal holding position and it went to portrait again. Tried FF, no go, it simply paused the display and sound and did NOT jump the counter ahead. 6 seconds later play resumed and no time was saved. More commercials (it was the half-way part where they put in a ton of commercials). I tilted the phone around to landscape and FF worked. Back to portrait it didn’t work, to landscape, FF worked again.

So, I WAS CORRECT! The updates didn’t fix a thing for some of us. When holding the phone like most people do when talking on it or accessing typical things it won’t FF.
Turn the phone on its side so it shifts to landscape mode and FF works like a charm.

@Tablosupport - Moto X phone, Android 4.4.2, latest Tablo web app, fast forward doesn’t work. Turn the phone on its side so it changes the screen to landscape and your FF button works fine.

I just tried it on my Moto G (2014) running Android 5.0.2, and FF works fine in both portrait and landscape mode.

Isn’t that interesting. It’s not just “my” phone either.
My wife’s phone does the same thing.

All of them (our two and your G) are Motorola phones, all have the later Android OS (4.4.x or later) and of the three - 1 works properly, 2 do not. 
I found it odd that I got a later player, too - well, it SAID it was later. Recall I’d checked and everything was up to date just a week ago. 

I did check on my son’s Moto G which is still running 4.4.4, and his works correctly as well.

It is strange.

I wonder if it’s something different about the Moto X and how it handles the screen. 

I guess only Tablo support ( @Tablosupport ) hint-hint  could tell me for sure…


We haven’t identified anything like this yet - but we’ll test ASAP to confirm. And just to be sure - you did update to the most recent version this week, correct?

@Tablosupport  and the resume feature as well, still broken for at least a month now… I should say, saving where you left off on the phone. Resume works as long as it was from another device.


We haven't identified anything like this yet - but we'll test ASAP to confirm. And just to be sure - you did update to the most recent version this week, correct?

@Tablosupport - sure did. I saw it coming in with the down arrow and looked to see what it was. Said yes, accepted/installed, used. Due to the other odds and ends I’ve tried to keep up with updates.

Now I can’t say if turning the phone would have mattered a few days ago - maybe, maybe not. But it did matter last night. 
I’ll be happy to launch the file manager on my phone to get any details you may need.