Terrible product

Which app are you using? That model needs the Legacy Tablo app https://play.google.com/store/apps/details?id=com.nuvyyo.TabloCordova for Android. If you installed the other Tablo app it is for the 4th gen white round Tablo.

This user has a legacy hardware problem (Loose antenna connector on a unit bought in 2022) which is not related to the app.

4th gen has been on Amazon since August 21, 2023 so I strongly suspect it’s the old hardware that he has.