Tablo won't stay on network - Now can't see network at all

I am posting here even though I have seen similar (not exact) incidents in this forum because none of these incidents that I have found are recent. (2020)

Tablo keeps dropping from network. All other devices are fine. This has been happening more and more frequently as of late. Not Tablo cannot see the network at all. I recently (2 weeks ago) renewed my Tablo to it’s factory settings to rid myself of TV show recording artifacts in the recordings section, but this network dropping issue has been happening before I performed this operation as well. This is on an Android TV device, Apple iPhone and Web browser.

I have a TP-Link mesh network where the Tablo is plugged in directly to the main router on the network. I have also tried unplugging the ethernet cable and tried to set it up to the Wi-Fi inside the Tablo. My Wi-Fi network sees the Tablo but will not complete the setup process.

Yes I have tried unplugging everything and one at a time. I even hit the reset button on the back of the Tablo with no change. By the blue LED indicator, my Tablo does not see my network even though I can see IT in the list of Wi-Fi devices.

Do I need a new Tablo device? I hope not. Mine is 5+ years old. It is an original Quad device. It seems like the network infrastructure inside my Tablo is dying maybe? IDK

Please do not come on here and just ask me to go through the troubleshooting steps on the Tablo website. I have gone though all these things more than once. Has anyone else had an issue like this where it appears that the Tablo network interface was dying and then died?

-Thank you.

The Tablo power supply might be dying.

You might want to buy a replacement one. You should able to buy one from the Tablo web site.

Interesting thought. Thank you sgnadeau. Has this happened to you too?

So is it possible for the the Tablo to power up and still be a power supply issue?

Yes, the current requirements go up significantly as each tuner is activated.

From what I’ve read it’s more prevalent with 4 tuner tablos.

I’ve had my 2 tuner tablo for 6 years now without any problems.

Also, my hard drive has its own power supply.

I’ll give it a shot unless I hear something else from someone else that changes my mind.


I’ve had issues with Roku, and Tablo devices connecting wirelessly due to the wireless router’s channel width setting.
There’s a separate channel width setting for each frequency: 2.4GHz; 5GHz.
The issue disappeared when setting the channel width lower on the frequency the problem devices were using.

This channel width issue seems to go away in our environment with wireless router firmware upgrades, only to come back with other wireless firmware upgrades.

Our final solution was to replace our wireless router with a newer model.

You could also have a heat problem. When I first got my Quad 4 back in September 2019, I had a similar problem where the unit would just disappear from the network. Unplug for a while and then reconnect and it would work fine. I ended up putting a cooling fan under the unit and I my problems were resolved.

If this doesn’t do the trick, give our support team a shout and we’d be happy to take a look.

I have had a fan pulling heat off my Tablo 4 tuner for years. In fact I had to replace the fan once because the bearings were making too much noise. LOL I ordered a new power supply from the Tablo website. We’ll see if that helps. I did notice that it is the block style plug now, vs the the regular plug to a separate block like box.

If that doesn’t do the trick, I’ll contact support.